Photo Station Uploader (Mac) Not Connecting over HTTPS

Questions about the Synology Photo Station can be placed here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
BJDeriso
Trainee
Trainee
Posts: 16
Joined: Thu May 26, 2011 4:46 pm

Photo Station Uploader (Mac) Not Connecting over HTTPS

Unread post by BJDeriso » Thu Mar 15, 2018 1:54 pm

I'm running Photo Station 6 on the standard HTTPS port (443). I have installed a Rapid SSL certificate and I am able to connect to every single service over HTTPS using a web browser and all of Synology's mobile apps except Photo Station Uploader for Mac. When I try to build a profile (default or user-specific Photo Station Account), and select the HTTPS option, I get a "Remote host closed the connection" error every single time.

It took a lot of sniffing around, but I think I've narrowed the problem down to the selection of TLS Cypher Suites in Control Panel > Security > Advanced. Photo Station Uploader (at least, the Mac version ) does not connect with "Modern Compatibility" selected -only "Intermediate", or "Backward Compatible" mode works.

Has anyone else experienced this, and does Synology have any plans to update their uploader client to use the latest encryption standards??

Post Reply

Return to “Photo Station”