calDAV with iOS5 devices STILL not working under DSM4

The discussion room of webDAV based solution for file sharing.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form: ... p?lang=enu

2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
I'm New!
I'm New!
Posts: 3
Joined: Fri Feb 24, 2012 4:19 pm

calDAV with iOS5 devices STILL not working under DSM4

Unread post by rlukey » Fri Mar 09, 2012 9:13 pm

So I can configure my iPad & iPhone to connect to the calendar which I've set up in DSM...
Not using https and keeping the default webdav port of 5005.

The server is called NAS411slim, the calendars are kept in the /calendars directory with each individual calendar as a sub directory e.g. /OurCalendar so the connection should look like this...


First problem, the iPhone (iOS5) refuses to accept the server hostname... it does accept the ip address... so it becomes:

Having entered everything into the iPhone and gone back into advanced settings to manually enter the Account URL field, the iPhone finally connects to the NAS...

Now I can create calendar entries from my iPhone and checking in DSM file browser all the .ics files are appearing in the /calendar/OurCalendar/ folder.

Second problem, after configuring the iPad it too can create calendar .ics files on the NAS, only the entries for each device cannot be viewed by each other, same goes for any .ics files added to the /calendar/OurCalendar/ folder.

End of the day, Synology said that DSM 4 would fix the issue... and it hasn't.

Dear Synology, When is this going to be fixed?

Post Reply

Return to “WebDAV”