Shared folder sync won't pass "test connection"

Discuss backup and restore functions of the DiskStation with respect other DiskStations, USB/eSATA, network backup, or other rsync clients.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
alan sh
Apprentice
Apprentice
Posts: 93
Joined: Wed Oct 02, 2013 3:25 pm

Shared folder sync won't pass "test connection"

Unread post by alan sh » Thu Mar 24, 2016 6:41 pm

Under 5.5.2, shared folder sync worked fine between two Synology boxes.

I've now updated to V6 and the sync keeps failing. When I go into it and click on "Test Connection", that always fails. I've checked the passwords, made sure that rsync is enabled in file services (it is) - bit I can't get it to work.

Anyone got any ideas?

Alan

alan sh
Apprentice
Apprentice
Posts: 93
Joined: Wed Oct 02, 2013 3:25 pm

Re: Shared folder sync won't pass "test connection"

Unread post by alan sh » Fri Mar 25, 2016 12:14 am

It looks like you use "Cloudstation Shared Sync" from the client machine which then pulls the data from the server. Very obtuse....

Alan

13brv3
I'm New!
I'm New!
Posts: 5
Joined: Sun Jun 10, 2012 5:19 pm

Re: Shared folder sync won't pass "test connection"

Unread post by 13brv3 » Mon Mar 28, 2016 7:49 pm

Same problem here. I've used this sync setup for years, and V6 seems to have killed it. I'm hoping this is a bug they will quickly squash.

Rusty

User avatar
syno.dustin
Sorcerer
Sorcerer
Posts: 2244
Joined: Thu Oct 29, 2015 11:03 pm
Location: Seattle, WA

Re: Shared folder sync won't pass "test connection"

Unread post by syno.dustin » Tue Mar 29, 2016 1:24 am

alan sh wrote:It looks like you use "Cloudstation Shared Sync" from the client machine which then pulls the data from the server. Very obtuse....

Alan
That's for bi-directional syncing rather than one-way.

Are you doing shared folder sync between the same DSM versions?
If you need technical support please use this form: https://account.synology.com/support/support_form.php
Synology does not consistently browse this forum for technical support, feature requests, or any other inquiries as it notes at the top of the page. Please use the proper channels when you need help from someone at Synology.

13brv3
I'm New!
I'm New!
Posts: 5
Joined: Sun Jun 10, 2012 5:19 pm

Re: Shared folder sync won't pass "test connection"

Unread post by 13brv3 » Tue Mar 29, 2016 2:24 pm

syno.dustin wrote:
Are you doing shared folder sync between the same DSM versions?
In my case, yes, I update both NAS boxes at the same time. I submitted a trouble ticket for the problem yesterday, and will update this thread with the results.

Cheers,
Rusty

13brv3
I'm New!
I'm New!
Posts: 5
Joined: Sun Jun 10, 2012 5:19 pm

Re: Shared folder sync won't pass "test connection"

Unread post by 13brv3 » Fri Apr 01, 2016 1:24 am

Greetings,

I've exchanged a couple messages with support, and they offered a suggestion that seems to work, and it's certainly nothing I would have figured out on my own.

Please try setting the DNS server settings (DSM Control Panel>Network>check off "Manually configure DNS server") to use the Google public DNS servers of 8.8.8.8 and 8.8.4.4 for the preferred and alternative respectively.

On both NAS boxes, I had my DSL router LAN IP address as the gateway and DNS. Unless V6 changed it, that's how it always was. From the tests I did today:

If I put my router LAN IP address for the DNS, I can get to internet, and access software updates, but the shared folder sync connection fails (since V6).

If I put nothing in the DNS, I can't access internet of course, but the shared folder sync works.

If I put the Google 8.8.8.8 in the DNS, then both work. I don't know how to enter an alternative, since there's only one field.

My folders are syncing as I type, using the 8.8.8.8 option.

Cheers,
Rusty

toxicman
I'm New!
I'm New!
Posts: 6
Joined: Tue Nov 06, 2012 10:03 pm

Re: Shared folder sync won't pass "test connection"

Unread post by toxicman » Sat Apr 02, 2016 7:10 pm

13brv3 wrote:Greetings,

I've exchanged a couple messages with support, and they offered a suggestion that seems to work, and it's certainly nothing I would have figured out on my own.

Please try setting the DNS server settings (DSM Control Panel>Network>check off "Manually configure DNS server") to use the Google public DNS servers of 8.8.8.8 and 8.8.4.4 for the preferred and alternative respectively.

On both NAS boxes, I had my DSL router LAN IP address as the gateway and DNS. Unless V6 changed it, that's how it always was. From the tests I did today:

If I put my router LAN IP address for the DNS, I can get to internet, and access software updates, but the shared folder sync connection fails (since V6).

If I put nothing in the DNS, I can't access internet of course, but the shared folder sync works.

If I put the Google 8.8.8.8 in the DNS, then both work. I don't know how to enter an alternative, since there's only one field.

My folders are syncing as I type, using the 8.8.8.8 option.

Cheers,
Rusty
Was having this exact problem after updating both my Synology NAS and this fixed the shared folder sync.

Tim789
I'm New!
I'm New!
Posts: 1
Joined: Tue Apr 05, 2016 5:11 pm

Re: Shared folder sync won't pass "test connection"

Unread post by Tim789 » Tue Apr 05, 2016 5:19 pm

Hi,
Since upgrading both my DS115j to DSM6.0 I have been having the same issue.

In my case, the only way to get Shared Folder Sync to work seems to be to set the DNS on the Network General tab to Manually Configured = not checked, AND the DNS on the Network Interface/LAN tab to blank, then reboot the NAS. The Shared Folder Sync will pass the tests and is syncing right now. Obviously the DSM update doesn't work as there is no DNS config.

As soon as I add my router as the DNS (in either of the General or LAN tabs) the shared folder sync fails again, but Update works. If I add the suggested 8.8.8.8 and 8.8.4.4 then neither sync nor update work.

So basically I can have one or the other (Shared Folder Sync or Updates) but not both, and I have to reboot the thing when I change it.

Ideas .....?

Thanks

Tim

************* UPDATED AND SOLVED ********************
It turns out that there is a 'useful feature' of BT Internet (My ISP) called Web Address Help. This is a DNS redirect to a web page containing 'useful links' if you mis-type a URL (in other words, an opportunity for someone to try to sell you something.) This is enabled by default and you need to disable it if you don't want it. See here (or search for 'BT WebAddressHelp') ...

https://community.bt.com/t5/Connected-D ... td-p/49804

Anyway, I already knew that this screws up my DNS when I'm connected to my work VPN, and it seems to screw up Shared Folder Sync too. Don't ask me how.
I had previously disabled it but it seems that since I switched to a new router, it has gotten enabled again.

So now I have disabled that, rebooted the router, set the DS115j to use my router as DNS and rebooted that, I get Shared Folder Sync *AND* updates.

Great. Thanks yet again, BT.

TuftyMcTavish
I'm New!
I'm New!
Posts: 2
Joined: Wed Nov 04, 2015 6:42 pm

Re: Shared folder sync won't pass "test connection"

Unread post by TuftyMcTavish » Thu Dec 28, 2017 3:20 pm

Hey, thanks Tim789, this appears to have solved my problem too. Error Code 10 reported in the log from failed syncs, Test Connection was also failing when I edited an existing Task or attempted to create a new one. After fiddling with your advice about BT and their Web Address Help I was able to start getting successful connection tests.

Thank-you for the follow-up.

Post Reply

Return to “Backup/Restore for DiskStation to DiskStation/USB/eSATA/Off-site backups”