rsync errors only affect photos folder

Discuss backup and restore functions of the DiskStation with respect to computer clients, such as Synology Data Replicator, Time Machine, or other client backup software.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
strange_cathect
I'm New!
I'm New!
Posts: 2
Joined: Sun Mar 29, 2015 4:42 pm

rsync errors only affect photos folder

Unread post by strange_cathect » Sun Mar 29, 2015 4:48 pm

I want to rsync to my Synology /photo folder. However, when I do so, errors are thrown. Strangely, I can rsync the same data to another shared NAS folder perfectly without errors. So I seem to have some kind of permissions problem that only affects the /photo folder. But my settings are identical to the folder that works correctly.

I can't figure out why. Whey I run:

Code: Select all

rsync -r -n -v --progress --delete --ignore-existing /home/jeff/Pictures/ /media/NAS_Photos
I get these errors:

rsync: recv_generator: mkdir . . . permission denied (13) {Then all contents are skipped}
rsync: recv_generatory: failed to stat . . . permission denied (13).

Can someone guide me through troubleshooting this?

Thanks.

Nootz
I'm New!
I'm New!
Posts: 6
Joined: Sun Feb 04, 2018 7:29 pm

Re: rsync errors only affect photos folder

Unread post by Nootz » Fri Mar 09, 2018 7:43 pm

I solved this problem in DSM 6.1.5 by going to Photo Station, going to Settings >> User Accounts >> Permissions >> Edit and adding Manage to the permissions of the rsync user.

Locked

Return to “Backup/Restore for computer clients”