[Solved] Upload to my Synology ftp via Linux

For issues regarding settings and usage of FTP and WebDAV service, post it here!
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu

2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
I'm New!
I'm New!
Posts: 5
Joined: Sun May 13, 2012 12:45 pm

[Solved] Upload to my Synology ftp via Linux

Unread post by okboy » Sun May 27, 2012 1:51 am

root@server1:~/backup# ftp -i -v -d username.synology.me
Connected to username.synology.me.
220 NAS FTP server ready.
ftp: setsockopt: Bad file descriptor
Name (username.synology.me:root): backup
---> USER backup
331 Password required for backup.
230 User backup logged in, access restrictions apply.
---> SYST
215 UNIX Type: L8
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> mput /root/backup/sql/*
local: /root/backup/sql/file1.sql.gz remote: /root/backup/sql/file1.sql.gz
---> PORT 76,79,79,242,183,201
No control connection for command: Success
Or if I simply use the put command (or 2 scripts I found online), I get
421 Timeout (300 seconds): closing control connection.
This also happens when using my IP address and not the DDNS. Using sftp results in this:
sftp backup@username.synology.me
Connecting to username.synology.me...
backup@username.synology.me's password:
subsystem request failed on channel 0
Couldn't read packet: Connection reset by peer
Of course, I've opened the right ports and tested the ftp with Cyberduck, and I can even ssh to the Synology via the Linux VPS.

In case you're wondering, I'm trying to backup the sites and databases on my VPS to my Synology NAS. When the scripts failed and I saw no one with the same problem I had, I tried just uploading something manually (sans-script) via ftp, sftp, etc. But no joy, either way.

EDIT: I changed the NAS to report PASV and added -p to the ftp command and it works now.

Post Reply

Return to “FTP & WebDAV Server”