ESXi 6 Update 2 NFS problem?

This room is for the discussion of how the Synology DiskStation can meet the storage needs for Virtual HyperVisors.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
matt-c
Novice
Novice
Posts: 40
Joined: Mon Sep 10, 2007 5:25 pm

ESXi 6 Update 2 NFS problem?

Postby matt-c » Fri Apr 22, 2016 3:59 pm

Hi.

I've opened a ticket, but just in case someone has any information?

I updated my ESXi to 6 Update 2 from Update 1 and all my NFS datastore are no longer accessible (713+ with DSM 6 latest).

They are in inactive state, quite annoying.
mamema
I'm New!
I'm New!
Posts: 5
Joined: Mon Mar 26, 2012 1:29 pm

Re: ESXi 6 Update 2 NFS problem?

Postby mamema » Fri Apr 22, 2016 8:33 pm

i have this already with an update from 4.3 to 5.2.5644 on a ds3612
vulturul
I'm New!
I'm New!
Posts: 6
Joined: Thu Feb 17, 2011 12:58 am

Re: ESXi 6 Update 2 NFS problem?

Postby vulturul » Sun Apr 24, 2016 12:20 am

Hello,

i have encountered the same issue:
- ESXi 6 updated to ESX6 update 2 build number 3620759
- DSM 6, update 3

after countless pointless debugging, i eventually turned to digging in the /var/log/vmkernel.log and found out it was a problem with the storage adapter, which in this case is the NIC (for NFS). I had a simple setup with a single NIC over which the vmkernel network was running to mount the NFS so i looked at the vmnetwork. Previous to updating the ESX to "update 2" i had set the MTU on both the vswitch and the vmkernel network to 9000. After the update, the vswitch was automatically set to 1500 and not able to be modified (driver update i suppose) but the vmkernel network was still stuck to 9000 MTU. I modified the vmnetwork down to 1500 MTU (ofc to match the NIC itself) and everything was back to normal (NFS datastores mounting, and VM traffic).

Hope if helps someone else aswell
mamema
I'm New!
I'm New!
Posts: 5
Joined: Mon Mar 26, 2012 1:29 pm

Re: ESXi 6 Update 2 NFS problem?

Postby mamema » Sun Apr 24, 2016 6:22 pm

Haven't configured jumbo frames, so must be anothef issues.
It's absolutely device dependent.
Same DSM on a 22xx 10 bay rackstation and a 12 bay 3612 Diskstation.
Same config. on Rackstation, DSM is working with NFS and esxi 6
Same config on Diskstation DSM is Not working with NFS and esxi 6
mamema
I'm New!
I'm New!
Posts: 5
Joined: Mon Mar 26, 2012 1:29 pm

Re: ESXi 6 Update 2 NFS problem?

Postby mamema » Sun Apr 24, 2016 6:22 pm

Haven't configured jumbo frames, so must be anothef issues.
It's absolutely device dependent.
Same DSM on a 22xx 10 bay rackstation and a 12 bay 3612 Diskstation.
Same config. on Rackstation, DSM is working with NFS and esxi 6
Same config on Diskstation DSM is Not working with NFS and esxi 6
matt-c
Novice
Novice
Posts: 40
Joined: Mon Sep 10, 2007 5:25 pm

Re: ESXi 6 Update 2 NFS problem?

Postby matt-c » Mon Apr 25, 2016 8:30 am

I'll have a look into jumbo frames, i was using 9k also. Thanks.

Looking forward to official response from Synology.
matt-c
Novice
Novice
Posts: 40
Joined: Mon Sep 10, 2007 5:25 pm

Re: ESXi 6 Update 2 NFS problem?

Postby matt-c » Thu Apr 28, 2016 9:07 am

I have reverted to ESXi 6 U1 for now.
cannfoddr
Beginner
Beginner
Posts: 23
Joined: Mon Nov 05, 2012 1:21 am

Re: ESXi 6 Update 2 NFS problem?

Postby cannfoddr » Tue Jul 26, 2016 8:42 pm

Hi,

I just updated to 6.02 and have a similar problem....

Digging through the vmkernal log I noticed I was getting lots of:

ATS-Only VMFS volume 'Synology i-SCSI' is not mounted. This host does not support ATS, or ATS initialization failed.

It looks like for me the VAAI features are no longer working and the volume won't mount.

I found a VMWARE KB article that advised changing:

VMFS3.HardwareAcceleratedLocking from 1 to 0

Did this and I was able to remount my datastore and start VMs...
nodoubt
I'm New!
I'm New!
Posts: 1
Joined: Sat Dec 17, 2016 2:22 am

Re: ESXi 6 Update 2 NFS problem?

Postby nodoubt » Sat Dec 17, 2016 2:53 am

Dear All,

Recently we hit a problem with 1 of our Synology RS18016XS box. seems the nfsd cannot handle the requests and causing connectivity haywire between ESXi and the storage. Once in a while, the storage is inaccessible. Due to that we start migrating out the machines to another storage. Since then, storage inaccessible happens very frequent so that we cannot do anything. since we used bonding with adaptive load balancing, we tried to disable one of the nic.

by doing disabling one of the nic, it stabilise for a while and thats permit us to do storage vmotion. but then it does not take long that later it happens again. so now with the link is only on 1 nic, and for some reason the nfs got stale, we had to do storage vmotion one by one until finish.

anybody happens the same ?

our setup :
3 esxi version Lenovo_6.0U1_20151125
2 Synology RS18016XS
1 EMC
100+ VM
EXi - Storage relies on NFS

The log captured on synology was

[Sun Dec 11 16:11:44 2016] rpc-srv/tcp: nfsd: got error -104 when sending 120 bytes - shutting down socket

My target is to storage vmotion out of the problematic synology, update the firmware, reboot and remount back to see whether the problem can be recreated or not. In the mean time, we are getting support from Synology but no respond yet. We are also getting support from vmware.

Return to “Virtual HyperVisors (VMWare/ESXi)”

Who is online

Users browsing this forum: No registered users and 1 guest