<SOLVED> Lost bootstrap after update to DSM DSM 5.0-4482

All discussions/development regarding the Marvell mv6281 Chip can be placed here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:


2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
I'm New!
I'm New!
Posts: 3
Joined: Tue Sep 03, 2013 9:36 am

<SOLVED> Lost bootstrap after update to DSM DSM 5.0-4482

Postby calagan » Wed Apr 30, 2014 5:40 am

UPDATE: ipkg and all my optware apps were still in /volume1/@optware (mounted as /opt), so this was an easier fix than I expected: re-adding /opt/bin and /opt/sbin in the PATH did the trick.

I rushed into updating my DS411slim to DSM 5.0-4482 in order to fix the Heartbleed vulnerability and I had a couple of unpleasant surprises.

First, I noticed that I could not receive any e-mails, as the update broke the postfix config of my Zarafa (own domain setup). I fixed it by reapplying the changes to master.template and main.template as described in http://www.zarafa.com/wiki/index.php/Za ... nology_NAS.

It got worse when I realised that bootstrap was gone after the update: "ipkg: not found" !!. I had installed it via the very convenient package from http://packages.quadrat4.de, but it turns out the developer decided to retire and his bootstrap package are not compatible with DSM 5.

I guess I'm left with installing bootstrap the hard way (unless ipkg is just hiding somewhere on my HDD?), but I can't seem to find the version that matches the mv6282 CPU of my DS411slim? Am I supposed to use the one below?

Thanks in advance,

User avatar
Posts: 6794
Joined: Sun Dec 27, 2009 12:13 pm
Location: Espoo, Finland

Re: <SOLVED> Lost bootstrap after update to DSM DSM 5.0-4482

Postby maxxfi » Mon May 05, 2014 6:32 am

Check the wiki article:
http://forum.synology.com/wiki/index.ph ... ,_ipkg_etc

The bootstrap that you should use is the syno-mvkw-bootstrap_1.2-7_arm-ds111.xsh mentioned there (that has a relaxed platform checking).

Note that if you were on 4.3 (and you're unhappy with 5.0), Synology has now published the hotfix for heartbleed.
No longer using Synology NAS, moved to more open source solutions.
DS-106j > DS-210j > DS-411

Return to “Marvell mv6281 Development Room”

Who is online

Users browsing this forum: No registered users and 1 guest