phpMyadmin showing: "The service is disabled now."

Discuss the phpMyAdmin Package Here.
Forum rules
We've moved! Head over to Synology Community (community.synology.com) to meet up with our team and other Synology enthusiasts!
yd82
I'm New!
I'm New!
Posts: 2
Joined: Wed Jan 22, 2014 3:09 am

phpMyadmin showing: "The service is disabled now."

Unread post by yd82 » Fri Feb 07, 2014 5:45 am

Hello,

After first installation of phpMyadmin, I can login to http://myNAS-IP/phpMyadmin using user/pass as default.

I can create xbmc account, all my xbmc client can using the mysql for database. However, after close the setup site. I can't login to http://myNAS-IP/phpMyadmin anymore.

It keeps showing: "The service is disabled now." without showing the login page.

I don't know how to fix it, uninstall and reinstall seem to work for the first time only. Is there any chance because of I changed the password???

Please help me...

Thanks

Long Vu.

synoParisFR
I'm New!
I'm New!
Posts: 2
Joined: Wed Feb 19, 2014 9:16 pm

Re: phpMyadmin showing: "The service is disabled now."

Unread post by synoParisFR » Fri Mar 14, 2014 11:14 pm

He,
I got same [Please control your language] bug. I have a DS214 : phpMyAdmin was ok with DSM 4.3. Upgrade to DSM 5 and phpMyAdmin is now broken "The service is disabled now". Try stop/restart PMA : no way. Try desinstall / install PMA : no way. Try restart NAS : no way. Check firewall rules : no way. Synology staff : could you promptly fix this [Please control your language] ? Synology is disabled now !

pppp41
I'm New!
I'm New!
Posts: 1
Joined: Sun Apr 06, 2014 9:37 am

phpmyadmin : the service is disabled

Unread post by pppp41 » Sun Apr 06, 2014 9:42 am

i have recently upgrade the DS713+ to DSM4.3-3827 update1. I have used the phpmyadmin from time to time but not in last month. And today found the phpmyadmin cannot be accessed with the error msg display: The Service is Disabled Now.

Tried to enable/disable mysql/web services and also install/uninstall but no luck. Any suggestion how I could resume the service.

Thanks.

ubelong2matt
I'm New!
I'm New!
Posts: 5
Joined: Thu Jan 30, 2014 4:21 pm

Re: phpMyadmin showing: "The service is disabled now."

Unread post by ubelong2matt » Thu Apr 10, 2014 7:58 pm

There is a rewrite rule in the .htaccess.syno file that redirects any attempt to get to phpMyAdmin with a redirect to a file called disabled.html. I'm not sure if this file remains due to something we have or have not done since the update but mine is still there, even after opening the MariaDB and entering my root password for MySQL.

http://trantor.synology.me/ruthpozuelo/ ... y-dsm-5-0/

That article talks about how to possibly get back into it but no where in that article does the author mention a disabled message.

You have two ways of fixing this as far as I can see. You can modify the .htaccess.syno file and either delete it or comment out the contents. You may need to restart your webserver using httpd -k restart from terminal before it will work. Also, Google Chrome likes to redirect you back to that page if it previously went there so you might need to reset Chrome's cache.

The other is to just go to https://your-site.com/phpMyAdmin/index.php and circumvent the redirect rule.

puddinq
I'm New!
I'm New!
Posts: 1
Joined: Thu Jan 15, 2015 11:29 am

Re: phpMyadmin showing: "The service is disabled now."

Unread post by puddinq » Thu Jan 15, 2015 11:39 am

:D Thanks!: ubelong2matt
I had the same problem: phpmyadmin the service is disabled now
What I tried
stop/ restart webservices and phpmyadmin / mariadb and system in various orders did not work.
What worked
The answer for me: just as ubelongtomatt stated the 'disabled page' was in chrome's cache
on my system it was in Chrome as wel as firefox. after a 'shift + f5' it worked.
I love my synology but feel sometimes issues take to much time.

Locked

Return to “phpMyAdmin”