DS212j and Slow Network/Data Transfer - Solved

IF your questions pertains to using the file server performance, transfer issues, jumbo frames tuning, post it here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:


2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
Posts: 812
Joined: Tue Feb 07, 2012 10:28 am

DS212j and Slow Network/Data Transfer - Solved

Postby duffykins » Wed Mar 07, 2012 10:10 am

As you will see from my other posts I was having problems with netwrok/data transfer speed. Sorry that this is a long post but it just might help others having similar issues.

Explanation and infrastructure overview as follows:-

Our business is website development (my wife) and photography and video (me). It was only me that was having the problem. My wife's PC is Win 7 Pro 32 bit; mine is Win 7 Pro 64 bit. Othher PCs on the network are Win XP Pro (yup, we still use that OS )

My PC has four internal drives

C: is a WD 10,000 rpm Raptor . Other than Windows work files and programs there is no data on this disc.
D: is a 500Gb WD Caviar Black used for data only (documents, photos, music, etc.)
E: is a 1Tb WD Caviar Black that I use for photo and video work in progress
F: is a 2Tb WD Caviar Black that I use for archived video projects and also as the storage device for videos that I stream to TV.

Network is in two 'parts'. The main network is cat5e cabled with a gigabit switch connecting the PCs and DS. The 'streaming' network is over Belkin AV200 Powerline which works perfectly well for media streaming. There is a connection between the networks to allow internet access via a Belkin wireless modem router which acts as the hub for the Powerline network (though we no longer utilise the wireless facility as everything is hard wired).

The purpose of the DS212j was, initially, to provide a backup for the various files that were held on our respective PCs so I configured it as JBOD using two new WD20EARX discs. Later this year, as funds permit, I will buy a four bay DS to act as a true NAS and then I will 'downgrade' the DS212j to act as a backup to the four bay unit. So far so good.

So the major data transfers that I wished to carry out were, firstly, to backup all of the data on my F: drive, then to back up other key data files on my D: and E: drives. My C: drive is backed up weekly using Macrium Reflect Pro.

I started copying the F: drive data first (not starting any of the other copies until that F: copying was completed) and it was the F: drive transfers that were proving problematic. As that particular drive was less than 18 months old it never occurred to me that it was the problem. In fact, the clue should have come from the erratic behaviour of Windows Explorer.

After much Googling and trial and error and support from Synology via a ticket I had raised, I was getting nowhere.

Then Synology support sent a list of things to try and that email included a link to WD Lifeguard, their HDD checking tool. Result: my F: drive is failing (I am currently backing up the data that remains on it - about 250Gb - and that will have taken 36 hours when completed!).

As soon as all of the data is secured it will be RMAd back to WD for replacement under warranty.

So, the problem looks like it is solved.

Sorry for the long description but I thought it might help if anyone else has a similar problem. As I said, the clue was in the erratic behaviour of Windows Explorer with that particular HDD.

EDIT: Here are the links to the manufacturers disc diagnostic tools on a PC to check if the hard discs are fine:

[Samsung HDD: ES-tool]
http://www.seagate.com/ww/v/index.jsp?l ... 48090aRCRD

[WD HDD: Lifeguard]

[Seagate HDD: Seatool]
http://www.seagate.com/www/en-us/suppor ... /seatools/

[Hitachi HDD: Drive Fitness Test]
DS412+, 4 x WD Red WD20EFRS, (all 2TB) in RAID 10
Back up to 4TB WDRed WD40EFRS via USB3 held in an Orico HDD enclosure.
BT HH6; TP-Link TL-SG1008D 8-Port Gigabit Switch
PCs running Win 7 Pro (mix of 32 and 64 bit)
Squeezebox Touch, 2 x Squeezebox Booms, various Samsung HDTVs
Everything connected via cat6.

Return to “File Server Performance”

Who is online

Users browsing this forum: No registered users and 3 guests