Media Server - Not Supported File Format [merged thread]

Discussion the beta DSM 2.2-0914 here. Please report all bugs to the Beta Program Manager.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
syno.allen
Synology Inc
Synology Inc
Posts: 784
Joined: Fri Aug 22, 2008 5:07 am

Re: Media Server - Not Supported File Format [merged thread]

Unread post by syno.allen » Tue Jul 21, 2009 12:03 am

EowynCarter wrote:What about .srt ?
Xbmc can see them, but i have to manually add then. My freebox don't see then at all. Does the DS supports srt ? how ?

And wooo, i don't know if that's xcmc, the ds, or both, but it works faster than it ever did.
XMBC can pickup the right subtitle using samba or local video sources but you need to manually select the subtitle file in UPnP (limitation of XBMC by internal testing)

Some clients like your freebox might filter the media types that are not supported. DiskStation will index subtitle files but the way to retrive subtitles may depend on the implemetation of players.

AlanIP
Novice
Novice
Posts: 40
Joined: Thu Oct 30, 2008 5:26 pm

Re: Media Server - Not Supported File Format [merged thread]

Unread post by AlanIP » Tue Jul 21, 2009 5:05 pm

someone should separate the xbmc issue out of this thread... Samsung DLNA has enough problems. The xbmc issue has diverted the issue away from the real Unsupported File Format problem with the Samsung tv's.

brad23456de
Beginner
Beginner
Posts: 21
Joined: Tue Jun 23, 2009 8:39 am

Re: Media Server - Not Supported File Format [merged thread]

Unread post by brad23456de » Wed Jul 22, 2009 10:29 am

Hi,

My Philips WAS6050 internet radio now also gives a "Track(s) not playable" error message for all MP3's on the Synology. Library browsing works, but as soon I want to play a song it gives that message.

any ideas?

Thanks,

Martin

brad23456de
Beginner
Beginner
Posts: 21
Joined: Tue Jun 23, 2009 8:39 am

upnp issues

Unread post by brad23456de » Thu Jul 23, 2009 9:55 am

Hi,

After the upgrade to 2.2 my Philips was6050 internet radio/upnp client can browse the mp3 music on the 109 but I get a message "Track(s) not playable" when I try to play any songs. I have done a re-index without any change and other clients work fine.

Any ideas?

Many thanks,

M.

syno.allen
Synology Inc
Synology Inc
Posts: 784
Joined: Fri Aug 22, 2008 5:07 am

Re: upnp issues

Unread post by syno.allen » Thu Jul 23, 2009 1:08 pm

brad23456de wrote:Hi,

After the upgrade to 2.2 my Philips was6050 internet radio/upnp client can browse the mp3 music on the 109 but I get a message "Track(s) not playable" when I try to play any songs. I have done a re-index without any change and other clients work fine.

Any ideas?

Many thanks,

M.
Did the WAS6050 work for other Media Servers or DSM 2.1 firmware ?

cogmios
Novice
Novice
Posts: 48
Joined: Sat Jun 09, 2007 3:32 pm

MKV Support

Unread post by cogmios » Thu Jul 23, 2009 6:29 pm

"New DLNA Compliant Media Server: Supports more video formats, including MKV, TS, M2TS, M2T, MTS, M4V, 3GP, 3G2, QT, SWF, DVR-MS, MOV, TRP, TP, and ISO."

So I started by testing a MKV file but it does not show up in the list (empty folder) on my Xbox360 that is.

The file is "Lost.S05E16E17.720p.HDTV.X264-DIMENSION.mkv" (available somewhere out there....)

Has anyone tested MKV files already?

doktor.notor
Enlightened
Enlightened
Posts: 473
Joined: Thu Sep 25, 2008 11:30 am

Re: MKV Support

Unread post by doktor.notor » Thu Jul 23, 2009 7:17 pm

cogmios wrote: The file is "Lost.S05E16E17.720p.HDTV.X264-DIMENSION.mkv" (available somewhere out there....)

Has anyone tested MKV files already?
Xbox does not support MKV. Neither does PS3. At least until they get DivX 7 upgrade.

Retiarius
Novice
Novice
Posts: 58
Joined: Tue Apr 08, 2008 12:18 pm

Re: Media Server - Not Supported File Format [merged thread]

Unread post by Retiarius » Thu Jul 23, 2009 8:44 pm

Denon AVC-A11XVA amp can no longer play mp3's with the DLNA server in the beta firmware. I was previously able to play the mp3's on the old uPNP server prior to upgrade.

Amp reports "File Format Error"
Every other client i have works fine (PS3, Xbox360, iTunes, Windows Media Player, XBMC)

According to Denon's documentation the client meets DLNA guidelines
Audio Media Client:
- Audio streaming from networked PC using Windows® Media Connect.
- Audio streaming from networked PC's designed to the DLNA (Digital Living Network Alliance) Guidelines.
- Supported audio formats are MP3, WAV (LPCM), and WMA.

The amp will play the same files via the Windows Media Server or XBMC media server.

syno.allen
Synology Inc
Synology Inc
Posts: 784
Joined: Fri Aug 22, 2008 5:07 am

Re: Media Server - Not Supported File Format [merged thread]

Unread post by syno.allen » Fri Jul 24, 2009 12:05 am

Retiarius wrote:Denon AVC-A11XVA amp can no longer play mp3's with the DLNA server in the beta firmware. I was previously able to play the mp3's on the old uPNP server prior to upgrade.

Amp reports "File Format Error"
Every other client i have works fine (PS3, Xbox360, iTunes, Windows Media Player, XBMC)

According to Denon's documentation the client meets DLNA guidelines
Audio Media Client:
- Audio streaming from networked PC using Windows® Media Connect.
- Audio streaming from networked PC's designed to the DLNA (Digital Living Network Alliance) Guidelines.
- Supported audio formats are MP3, WAV (LPCM), and WMA.

The amp will play the same files via the Windows Media Server or XBMC media server.
There is a Denon 3808CI in our lab and works fine. Can you update to the latest firmware in Denon ?
If still not works, is it possible to contact the beta support and provide remote access such that we can collect somg logs ?

khellman
I'm New!
I'm New!
Posts: 1
Joined: Fri Jul 24, 2009 4:19 am

Re: Media Server - Not Supported File Format

Unread post by khellman » Fri Jul 24, 2009 4:31 am

syno.allen wrote:I just search around for Samsung TV specific mime type handling:
Please edit the mimtypes.txt and try again the following:

Code: Select all

Replace
avi   video/avi
with
avi   video/mpeg
See the twonkey topic.
I have the same Samsung LED TV as the original poster, and this fix did not work either. FWIW, .mkv, .mpeg, .wmv files that play from a USB drive connected to the TV, do not play when streamed from the DS either. MP3, and JPG are OK.

seedar
Apprentice
Apprentice
Posts: 85
Joined: Sun Jul 26, 2009 2:29 pm

DLNA with Sony Bravia z5500 TV

Unread post by seedar » Sun Jul 26, 2009 2:37 pm

I have found photos and music from iTunes work really nicely even with album art for some of my albums - need to track down why only some but must be something to do with my iTunes library. Its great, really like the handling of both photos and music - thanks Synology !

Video is a different matter but I suspect this isnt a Synology problem as I cant even get any video to work on the bravia from USB stick either ! The TV is supposed to support AVCHD and MPEG 2 from what I have read but I have tried AVCHD, MPEG 1, MPEG 2 and anything else I could think of but all result in an unable to play type message ???? Anyone know the answer here ?

thanks,
Seedar.

PS: Using a DS209.

brad23456de
Beginner
Beginner
Posts: 21
Joined: Tue Jun 23, 2009 8:39 am

Re: upnp issues

Unread post by brad23456de » Mon Jul 27, 2009 11:20 am

syno.allen wrote:
brad23456de wrote:Hi,

After the upgrade to 2.2 my Philips was6050 internet radio/upnp client can browse the mp3 music on the 109 but I get a message "Track(s) not playable" when I try to play any songs. I have done a re-index without any change and other clients work fine.

Any ideas?

Many thanks,

M.
Did the WAS6050 work for other Media Servers or DSM 2.1 firmware ?
The WAS6050 did not work with the old firmware (the main reason I upgraded was to get it working, because it does work with my FritzBox upnp server)), however, previously I couldn't browse the server, it would find the server but not the content on it. I could however "push" content from the Synology via PlugPlayer to the was6050.

Now I can browse the server but can't play anything "Track(s) not Playable" even push via PlugPlayer no longer works (was6050 crashes). I have tried auto format conversion feature on the Synology which doesn't change anything.

I have another WAS7500 which works under both firmwares.

Could this also be a mime issue?

Thanks,

Martin

syno.allen
Synology Inc
Synology Inc
Posts: 784
Joined: Fri Aug 22, 2008 5:07 am

Re: upnp issues

Unread post by syno.allen » Mon Jul 27, 2009 11:45 am

brad23456de wrote:
The WAS6050 did not work with the old firmware (the main reason I upgraded was to get it working, because it does work with my FritzBox upnp server)), however, previously I couldn't browse the server, it would find the server but not the content on it. I could however "push" content from the Synology via PlugPlayer to the was6050.

Now I can browse the server but can't play anything "Track(s) not Playable" even push via PlugPlayer no longer works (was6050 crashes). I have tried auto format conversion feature on the Synology which doesn't change anything.

I have another WAS7500 which works under both firmwares.

Could this also be a mime issue?

Thanks,

Martin
I suspect it's not a mime issue as mimetype of mp3 (audio/mpeg) is a widely accepted standard.
Is it possible contact the beta support and provide remote access information such that we can turn on the logs information and collect it later ?

User avatar
jekyll
Wizard
Wizard
Posts: 1832
Joined: Thu Feb 28, 2008 7:55 pm
Location: Epworth - UK
Contact:

Re: Media Server - Not Supported File Format [merged thread]

Unread post by jekyll » Mon Jul 27, 2009 12:24 pm

Same problem here, my MP101 has played since 3.xx firmwares..
After installing DSM 2.2 some MP3's refuse to play :(

I know it worked before (i listen to pink floyd a lot) and now some albums refuse to play :evil:

Also, Syno... what have you done to the way data is read from the server?
It used to have the data on multiple lines of the display.. it now will put all info on the top line of the LCD only :evil:
Synology DS1010+ 4.3-3827-U8 | DS410 4.3-3827-U7 | DS509+ 4.2-3252 | DS209+ 3.1-1748 | VS80 x 2

APC UPS1500RM2U | APC AP7920 | Linksys SRW224G4P | Linksys SRW224G4 | 802.3af IP cameras x 10

www.jekyll.info

syno.allen
Synology Inc
Synology Inc
Posts: 784
Joined: Fri Aug 22, 2008 5:07 am

Re: Media Server - Not Supported File Format [merged thread]

Unread post by syno.allen » Mon Jul 27, 2009 12:58 pm

jekyll wrote:Same problem here, my MP101 has played since 3.xx firmwares..
After installing DSM 2.2 some MP3's refuse to play :(

I know it worked before (i listen to pink floyd a lot) and now some albums refuse to play :evil:

Also, Syno... what have you done to the way data is read from the server?
It used to have the data on multiple lines of the display.. it now will put all info on the top line of the LCD only :evil:
Hi Jekyll:
Is it possible to give more details ?
  • So you can browse the music titles according to menu structure without problems but when start playing some mp3s, it refused to work and some indeed work ? Is it possible to submit the problemic mp3 file to us ?
  • I believe there might be some settings in MP101 to affect the lines of LCD display insead of server. The media server has no way to control the player LCD.

Locked

Return to “Beta - Disk Station Manager 2.2-0914”