Anyone else have printer probs with 2.1-0839?

The amended update to DSM 2.1-0832, discussion 2.1-0839 here. Updated services included "User Home" folders, File Station 2, and Download Station 2. DSM 2.1-0839 is avaiable for all currently supported x07, x08, and x09 Synology systems.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
jtanner
Trainee
Trainee
Posts: 12
Joined: Wed Apr 30, 2008 2:56 pm

Anyone else have printer probs with 2.1-0839?

Unread post by jtanner » Wed Apr 22, 2009 12:54 am

Just upgraded to 2.1-0839 on a DS207. Had a usb HP deskjet 952c hooked to it working fine until this latest FW upgrade. Now it prints half a page everytime. Printer works fine directly hooked to a machine.

Just a coincidence? or is the FW upgrade causing this?

James

User avatar
jekyll
Wizard
Wizard
Posts: 1832
Joined: Thu Feb 28, 2008 7:55 pm
Location: Epworth - UK
Contact:

Re: Anyone else have printer probs with 2.1-0839?

Unread post by jekyll » Wed Apr 22, 2009 1:13 am

Hello jtanner,
i can confirm that other users have experienced this problem.
it's more printing graphics than text.

a downgrade is possible although not officially supported.

i can point you in the right direction should you wish to downgrade...

Regards
Last edited by jekyll on Wed Apr 22, 2009 1:45 am, edited 1 time in total.
Synology DS1010+ 4.3-3827-U8 | DS410 4.3-3827-U7 | DS509+ 4.2-3252 | DS209+ 3.1-1748 | VS80 x 2

APC UPS1500RM2U | APC AP7920 | Linksys SRW224G4P | Linksys SRW224G4 | 802.3af IP cameras x 10

www.jekyll.info

jtanner
Trainee
Trainee
Posts: 12
Joined: Wed Apr 30, 2008 2:56 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by jtanner » Wed Apr 22, 2009 1:19 am

Well Crap. I can get by without using the DS207 as a print server for now, though that was extremely handy. Before downgrading, I think I will just wait with hopes that maybe it will be fixed with the next FW update.

Thanks for the info, much appreciated.

James

4rings
Student
Student
Posts: 60
Joined: Fri Jun 13, 2008 3:50 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by 4rings » Wed Apr 22, 2009 3:51 pm

I have this same problem since upgrading to 2.1-0839, however, I first noticed it when printing from a Mac laptop. I haven't noticed it when printing from my Windows machine. Surely the solution is not to downgrade. I upgraded so my DS207+ would hibernate and I don't want to lose that functionality. I have not tried uninstalling and reinstalling the printer on the Mac laptop yet but wondering if that is a possible fix.
Device: Synology DS-207+
Firmware: DSM 3.1 1636
Equipped w/: Seagate Barracuda 500GB HD x2

rick
Trainee
Trainee
Posts: 11
Joined: Sat May 19, 2007 7:38 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by rick » Wed Apr 22, 2009 8:35 pm

I can confirm the printer problems on my 106J with a Brother 5150 connected. I had never problems printing. After the latest update I am expieriencing problems with almost every printjob I send to the printer. I tries printjobs from a Windows XP, a Windows Vista and a Ubuntu workstation, alle the same problems. Sometime documents do nog print at all, sometimes they only print the first page, sometimes I have to push the button on the printer to activate the job. It occurs especially on document with photo's or other graphics.

This is very annoying because my printer is nog in the neighbourhood of a PC so I can only print on the network to the Synology.

Can anyone else conform this and is there a solution or workaround for this?

smhaller
I'm New!
I'm New!
Posts: 3
Joined: Fri Apr 24, 2009 11:57 am

Re: Anyone else have printer probs with 2.1-0839?

Unread post by smhaller » Fri Apr 24, 2009 12:09 pm

Hi all,

great that I'm not alone with that problem. It seems to me, that there is a problem with the data handling. So when you send bigger (amount of data) printouts, it memorizes the first part and starts printing. Only text usually 3 pages with my Canon S750. Printing PDF's with pictures made 2 pages. The print job afterwards got lost and the printer stays where it was and needs a reset.
Re-Installing the printer itself does not seem to help either. I have connected the printer to the workstation again until we get a patch for this bug.

Regards,
Stefan Haller

schnuffle
I'm New!
I'm New!
Posts: 3
Joined: Sat Apr 25, 2009 10:28 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by schnuffle » Sat Apr 25, 2009 10:37 pm

Hello,
I can confirm the same behaviour printing from two different Ubunte Desktops. On the Synology DS107+ I have a HP Laserjet 3030 and a Deskjet 990Cxi.

Both show the same behaviour indicating that all print data that does not fit into the printer memory is lost. Depending on the data printed I get several pages printed or just one, with graphics sometimes not even one Page.

Hope an update is provided soon as by buro colleagues are starting to get mad. :)


Have fun

Marc

youngcj3
I'm New!
I'm New!
Posts: 2
Joined: Thu Apr 23, 2009 9:48 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by youngcj3 » Sun Apr 26, 2009 10:07 am

Having just bought a DS408 I thought it was a 'feature' that this stopped printing half-way through a page! - I worked around it by using the recommended alternative printing approach of using a local TCP/IP port (see http://www.synology.com/support/faq_sho ... u&q_id=216).

This solved the problem on my Epson Stylus Photo RX640. The only problem I've had with this method is that the manual duplex no longer seems to work - it only starts printing when you say the sheets have been turned-over and then prints everything in the right order but on separate sheets of paper.

hewimeddel
I'm New!
I'm New!
Posts: 6
Joined: Thu Sep 18, 2008 11:26 am

Re: Anyone else have printer probs with 2.1-0839?

Unread post by hewimeddel » Mon Apr 27, 2009 5:16 pm

Same problem here - printing with my mac is near impossible, printing with my Windows XP-Laptop functions often but not always.

This behaviour started with 0832, but i always thougt, the problem was with my mac. Obviously not.

I own a DS 106j and a Canon IP4000-Printer.

Hope this gets solved.

bye
hewi

User avatar
Willem52
Apprentice
Apprentice
Posts: 87
Joined: Mon May 12, 2008 7:41 pm
Location: Netherlands
Contact:

Re: Anyone else have printer probs with 2.1-0839?

Unread post by Willem52 » Mon Apr 27, 2009 5:47 pm

Please,
Submit a support form to be sure this will be investigated by
Synology and the problem will be solved in a firmware update...
Synology DS-116

schnuffle
I'm New!
I'm New!
Posts: 3
Joined: Sat Apr 25, 2009 10:28 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by schnuffle » Thu Apr 30, 2009 11:18 pm

Okay I submited a report with an link to this thread. Hope there will be some progress soon

Regards

Marc

tulear
Trainee
Trainee
Posts: 13
Joined: Wed May 06, 2009 2:21 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by tulear » Wed May 06, 2009 2:25 pm

Hello,

I've got the same issue, do you any update from Synology support ?
Release note for 2.1-0844 does not seem to mention a correction for that problem ...

4rings
Student
Student
Posts: 60
Joined: Fri Jun 13, 2008 3:50 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by 4rings » Wed May 06, 2009 3:28 pm

Does DSM 2.1-0844 fix this print issue?
Device: Synology DS-207+
Firmware: DSM 3.1 1636
Equipped w/: Seagate Barracuda 500GB HD x2

schnuffle
I'm New!
I'm New!
Posts: 3
Joined: Sat Apr 25, 2009 10:28 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by schnuffle » Fri May 08, 2009 11:02 am

I got an answer from the Support.

Very polite but useless. The answer tells me that I use unsupported printers. So I think I'll have to investigate myself to see whats going wrong

Have Fun

Marc

4rings
Student
Student
Posts: 60
Joined: Fri Jun 13, 2008 3:50 pm

Re: Anyone else have printer probs with 2.1-0839?

Unread post by 4rings » Mon May 11, 2009 11:33 am

Reinstalling our printer on my wife's Mac using the technique described here has enabled her to print again:
http://forum.synology.com/wiki/index.ph ... c_Computer
Can someone in Synology support comment on whether this is temporary or a permanent solution?

Also, for you Windows users, have you tried this technique? I received this reply initially from support:

Please try adding the printer as a local printer manually, and selecting new port (type TCP/IP).

Device Type: Automatic Detection
Host name or IP-address: 192.168.x.x (whatever is the applicable address for the server)
Port name: IP_192.168.x.x_1
Choose protocol: LPR
Queue name: usbprinter
LPR byte count enabled
Device: Synology DS-207+
Firmware: DSM 3.1 1636
Equipped w/: Seagate Barracuda 500GB HD x2

Locked

Return to “Disk Station Manager 2.1-0839”