DSM2.1-0844 for DS-101g+ Discussion

Discussion Room for Legacy Disk/Cube/Rack Station from the x01/x06 Series.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
simcom
Trainee
Trainee
Posts: 15
Joined: Wed Sep 09, 2009 5:55 am

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by simcom » Thu Dec 17, 2009 3:55 am

jdreesen:
That's awesome work, thanks for the news! Which RAM chips did you use? (the part# on the chips)

mhcnet:
LED flashing is a good sign. Now install Synology Assistant on a PC (on the same network), and use the search feature. It will find an uninitialized Synology device and ask for the firmware file. Choose the firmware with the dirty hack.

jdreesen
I'm New!
I'm New!
Posts: 3
Joined: Wed Dec 16, 2009 1:25 pm

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by jdreesen » Sun Jan 03, 2010 8:50 pm

For the RAM chips I used a Samsung K4S561632 DRAM chip, I have datasheets for these and the originals used in the 101G+.
I have some more left if you want to have a go. I think however that more than just the soldering is required....

Update : read the CPU datasheet, seems I need to configure the 8241 for a 64 bit wide ram databus.
I need to figure out if the PIC is responsible for this. cn1 is the PIC in-circuit access port , so their may yet be a way to update the DS101G.

kenyoung
I'm New!
I'm New!
Posts: 1
Joined: Thu Mar 04, 2010 5:52 pm

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by kenyoung » Tue Mar 09, 2010 12:29 am

Dear jekyll,

I've upgraded the DS-101G+ with your patch in the FTP to the "106-0640" but I can not further upgrade it with new firmware. A message "Error 16 (Note: System volume is insufficient to extract upgrade patch, please backup all files and restore to factory default.)" appear and the upgrade stopped. Any hints!

Thank you!

Midtjyden
Sharp
Sharp
Posts: 189
Joined: Sat Feb 20, 2010 12:21 pm
Location: Silkeborg, Denmark

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by Midtjyden » Tue Mar 09, 2010 6:05 pm

I'm stuck there too. :cry:

I don't mind reformatting the hole disk, as I assume it is the system partition, that isn't large enough.

But how to get the little baby to install a firmware, that creates a bigger system partition?
DS409+ | DSM 2.3-1141 | 4 x 2TB Hitachi HDS722020ALA330 RAID5
DS408 | DSM 2.2-0965 | 2 x 2TB Western Digital WD20EARS RAID0 + 1TB Western Digital WD10EADS
DS101g+ | DSM 2.3-1141 (Goetz hack and guide) | 1 x 500GB Seagate ST3500630AS

Midtjyden
Sharp
Sharp
Posts: 189
Joined: Sat Feb 20, 2010 12:21 pm
Location: Silkeborg, Denmark

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by Midtjyden » Sun Mar 14, 2010 3:38 pm

I have just with success from scratch installed DSM 2.2-0959 for DS-106e on my trusty DS-101g+. :D
The DS-101g+ was on DSM 2.0-0731 for DS-106e before I scratched the disk.
My intention was to go all the way to 2.3-1139, but then it hit me: What if I need to reinstall the firmware from scratch? :?

The diskstation remembers which firmware revision that was last installed on the unit. And the DSAssistent won't let you install an older version of the firmware - even if your disk is completely blank.

Has anyone tried this on a DS101g+, DS106e - upgrade to DSM 2.3-1139, scratching the disk and then installing DSM 2.3-1139 again?
Is it as simple as just grabbing the same .pat-file, used to do the upgrade, and installing that from the DSAsssistent? Or is some patching required in the .pat-file?
DS409+ | DSM 2.3-1141 | 4 x 2TB Hitachi HDS722020ALA330 RAID5
DS408 | DSM 2.2-0965 | 2 x 2TB Western Digital WD20EARS RAID0 + 1TB Western Digital WD10EADS
DS101g+ | DSM 2.3-1141 (Goetz hack and guide) | 1 x 500GB Seagate ST3500630AS

efceed
I'm New!
I'm New!
Posts: 4
Joined: Thu Mar 18, 2010 10:09 pm

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by efceed » Fri Mar 19, 2010 4:56 am

I can't speak for the DS-101g+, but on my DS-106e with the DS-107 firmware, after the firmware update it becomes flashed to a 'DS107' i.e that is what it is identified as by Synology Assistant, so you can reinstall the DS107 firmware from scratch. Very useful if you want to get the partitions aligned with a new WD EARS drive :)

Midtjyden
Sharp
Sharp
Posts: 189
Joined: Sat Feb 20, 2010 12:21 pm
Location: Silkeborg, Denmark

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by Midtjyden » Fri Mar 19, 2010 2:58 pm

I came to the same conclusion - and I have allready upgraded my DS101g+ to fw 1139 from the DS107. :D

Impressive that this little baby is still running steady with the newest firmware. :D
DS409+ | DSM 2.3-1141 | 4 x 2TB Hitachi HDS722020ALA330 RAID5
DS408 | DSM 2.2-0965 | 2 x 2TB Western Digital WD20EARS RAID0 + 1TB Western Digital WD10EADS
DS101g+ | DSM 2.3-1141 (Goetz hack and guide) | 1 x 500GB Seagate ST3500630AS

User avatar
remyx
I'm New!
I'm New!
Posts: 4
Joined: Mon Mar 22, 2010 11:00 am
Location: Lausanne, Switzerland

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by remyx » Mon Mar 22, 2010 11:29 am

Hi Folks,
As I am pretty new in such hack, I will need all your knowledge.

I read that Goetz (thanks to him) made a hack to make a DS-101g+ to 106, and then to 107.

It seems to me, according to this link
http://forum.synology.com/wiki/index.ph ... y_NAS_have
that the DS-101g+ is more close to the DS-106e or DS-107e. True or wrong ?

By the way, 10'000 thanks to Jekyll and his very well made site, with the magical FTP.
It is great for us, apprentices, to have the tutorial in your hack zip. Very helpfull. :D

Thanks in advance for your answer
Remyx
At Home:
DS-101g+ - Flashed to DS-107 (Thanks to Jekyll)| DSM 3.0-1354 | 1 x 250GB Western Digital WD2500JS
DS-211+ | DSM 4.1 | 2 x 2TB Western Digital WD20EARS

david_hok
I'm New!
I'm New!
Posts: 4
Joined: Fri Nov 06, 2009 3:28 pm

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by david_hok » Wed Mar 24, 2010 5:29 am

My story is like this, please help, all experts..

Following the hacks in this forum, I've successfully upgraded DSM 2.2-0959 onto my 101g+, everything runs perfect, thanks a ll experts.

Last night, I tried to taste the beauty of DSM 2.3-1141 and follow the instructions in some other posts.

1) Download the DS-107 patch file from official website
2) Logon to my 101g+ as root and changed the synoinfo.conf (from 106 --> 107)
3) Load the firmware 1141 from the DSM 2.2 interface, then of course it reboots automatically afterall
4) I've successfully got DSM 2.3 running, no problem at all. I can even use the FileStation 3.
5) Then, I log on as root again and change the settings from 107 back to 106 (and some other power on > off settings) per described in other post
6) Reboot, this time, the signal light flashes... and of course, cannot log on to DSM 2.3 anymore

Using the Synology Assistant, I can still find my 101g+. However, I tried to load (from Syno Assistant tool) different versions of firmware but it doesn't allow me to. I've tried (in sequence) :
a) DSM 2.3-1141 for DS-107 (it stops after formatting the system partition)
b) modified DSM 2.2-0959 for DS-106 (found in another post, the same one I use it to upgrade 3 months ago). It stops again and says I need 107 firmware to continue..

This morning, I unplug the HDD and checked via IFS Drive, I noted the system partition is reported "Not Formatted", the other system related one only keeps the "lost & found" directory. Luckily, the 3rd partition shows my data is still there.

Now, my question is.. do I need to buy a new one or some experts can guide me how to have my 101g+ back into service? I hope it's not write-off .... I love my 101g+ ...

Please share your expertise as I'm quite new to the Linux system.. Thanks in advance, all experts !

ps : I haven't put anything extra (IPKG) onto my 101g+ from day one.

David

goetz
Knowledgeable
Knowledgeable
Posts: 336
Joined: Wed Mar 18, 2009 10:05 pm
Location: Berlin, Germany

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by goetz » Wed Mar 24, 2010 2:16 pm

Hi,
try again once more 1141 for DS-107.
Did you change unique back to 106? Do not do this!

Regards Goetz
DS-209+II / DSM 3.1-1742 /2x 2TB Seagate Constellation ES
DS-107+ / DSM 3.1-1613 / Samsung HD103UI
DS-106 / DSM 3.1-1742 (from 108j) / Hitachi HDP72505
eTrayZ / Samsung HD103SI

a_tung
I'm New!
I'm New!
Posts: 4
Joined: Sun Mar 14, 2010 4:40 am

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by a_tung » Wed Mar 24, 2010 3:41 pm

goetz wrote:Hi,
try again once more 1141 for DS-107.
Did you change unique back to 106? Do not do this!

Regards Goetz
I think David do change back the unique to 106 too... cause I did it before...

If do so, after reboot the nas then the status light will change to blinking amber... Luckily synology assistant still able to find the nas but said that the configuration is corrupt...
What I can do is re-update the firmware and then modify the synoinfo.conf without changing back the line of unique="synology_powerpc_106"

Hi Goetz, can you tell me what should I modify on the 101g+ synoinfo.conf? Since my friend have one 101g+, is it same as 106? Thanks!

Anthony

david_hok
I'm New!
I'm New!
Posts: 4
Joined: Fri Nov 06, 2009 3:28 pm

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by david_hok » Wed Mar 24, 2010 6:07 pm

thanks a lot man !! I successfuly put the DSM 2.3 - 1141 into my 101g+

so, after the firmware update, do I have to change anything in /etc.defaults/synoinfo.conf ??
I saw from another post "DSM 2.3 on DS-106e" that it requires to switch back the settings like systemperature and systemfan from "yes" to "no"

Is it the same case for 101g+ ?? Please kindly advise

Thanks,
David

Midtjyden
Sharp
Sharp
Posts: 189
Joined: Sat Feb 20, 2010 12:21 pm
Location: Silkeborg, Denmark

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by Midtjyden » Wed Mar 24, 2010 7:05 pm

I've changed my settings to these listed under DS-106e.
http://forum.synology.com/enu/viewtopic ... 120#p89779
DS409+ | DSM 2.3-1141 | 4 x 2TB Hitachi HDS722020ALA330 RAID5
DS408 | DSM 2.2-0965 | 2 x 2TB Western Digital WD20EARS RAID0 + 1TB Western Digital WD10EADS
DS101g+ | DSM 2.3-1141 (Goetz hack and guide) | 1 x 500GB Seagate ST3500630AS

goetz
Knowledgeable
Knowledgeable
Posts: 336
Joined: Wed Mar 18, 2009 10:05 pm
Location: Berlin, Germany

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by goetz » Wed Mar 24, 2010 7:20 pm

Hi,
only differences between 106 and 106e are
downloadlimit="10" insert for 106e
surveillance_camera_max="1" change for 106e
supportdomain="yes" delete for 106e
DS-101g+ has 64MB ram, so you can use settings for 106.

Regards Goetz
DS-209+II / DSM 3.1-1742 /2x 2TB Seagate Constellation ES
DS-107+ / DSM 3.1-1613 / Samsung HD103UI
DS-106 / DSM 3.1-1742 (from 108j) / Hitachi HDP72505
eTrayZ / Samsung HD103SI

david_hok
I'm New!
I'm New!
Posts: 4
Joined: Fri Nov 06, 2009 3:28 pm

Re: DSM2.1-0844 for DS-101g+ Discussion

Unread post by david_hok » Mon Mar 29, 2010 8:30 am

Just want to say thank you to all of you. I've successfully upgraded my 101g+ to DSM 2.3-1141. Thanks a lot !

David

Post Reply

Return to “x01/x06/x07 Legacy Discussion”