inofficial fw updates on cs 406

Discussion Room for Legacy Disk/Cube/Rack Station from the x01/x06 Series.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
swt
I'm New!
I'm New!
Posts: 5
Joined: Tue Mar 13, 2007 7:37 am

Re: firmware 1636 on cs 406

Unread post by swt » Thu Sep 19, 2013 1:10 pm

Hello, had firmware 1955 on my CS406 succesfuly, but then had to (kind of "switch owner" situation) completely replace disks and start device fresh. It become uninstallable so far. I downloaded pat files, but every time I try to install any version (using Synology Assistant) it says "You have to use 1955 or higher".

I am out of options and opinions, CS406 is now just a brick so any help would be GREATLY appreciated.

User avatar
maxxfi
Compiler
Compiler
Posts: 6794
Joined: Sun Dec 27, 2009 12:13 pm
Location: Espoo, Finland

Re: firmware 1636 on cs 406

Unread post by maxxfi » Thu Sep 19, 2013 2:44 pm

Even if you replace the disks, you cannot install an older firmware.
So, did you try to install the same .pat file that you previously used to install 1955 ?
No longer using Synology NAS, moved to more open source solutions.
DS-106j > DS-210j > DS-411

swt
I'm New!
I'm New!
Posts: 5
Joined: Tue Mar 13, 2007 7:37 am

Re: firmware 1636 on cs 406

Unread post by swt » Thu Sep 19, 2013 4:18 pm

Thanks for reply, maxxfi.
After frenetic and long experimentation, I found out working combination of 1955 pat file through 0844 Assistant, though I would swore I tried it already before. For record, I started trying 1955 pat and only after fail I tried to use last official etc.

pjhwils
I'm New!
I'm New!
Posts: 7
Joined: Wed Feb 10, 2010 6:44 pm

Re: firmware 1636 on cs 406

Unread post by pjhwils » Tue Oct 08, 2013 10:37 am

Alfredo wrote:I should really remove that file from my server because you're not the first one to tell me there's an error. Apparently I did something wrong when compiling it. Since it's an experimental firmware with some features not working (such as the LEDs), I don' think I'll be redoing it any time soon. Sorry.
Hi Alfredo, I had my CS406e on 3.1 1635, which worked fine, except for an rsync bug that made it impossible to backup from a DSM4.2 station to this 3.1. Synology delivered a fix for this, but only for version 1637: the last version for the x07 series, but not available for the x06 series.

I then decided to make a CS407e out of my CS406e by updating the synoinfo.conf, but installation with DS Assistant (with DSM 3.1 1637 for 407e) crashed and rendered my box empty with no fw, expecting a fw for CS406e. It is only accessible via telnet with a secret password, known by Synology only. DS Assistant expects at least a 1637 for the CS406e.

Do you happen to have a newer (1637 onwards) version for the CS406e? I'd be very thankful!

clickandgo
I'm New!
I'm New!
Posts: 3
Joined: Thu Aug 29, 2013 8:21 pm

Re: firmware 1636 on cs 406

Unread post by clickandgo » Sun Nov 24, 2013 7:19 pm

Do anyone have a link, for beta firmware 4.x.?:D

I would like to downlolad it and try it out:D

edmond
Versed
Versed
Posts: 282
Joined: Sat Jan 06, 2007 10:10 am

Re: inofficial fw updates on cs 406

Unread post by edmond » Mon Nov 25, 2013 8:12 pm

yes i have the 4.1 en 4.2 link
but not the 4.0 http://59.124.61.242/download/beta/

clickandgo
I'm New!
I'm New!
Posts: 3
Joined: Thu Aug 29, 2013 8:21 pm

Re: inofficial fw updates on cs 406

Unread post by clickandgo » Tue Nov 26, 2013 6:11 pm

Hello and thank you very much for the link, but i dont see a dl link for ds 406?

User avatar
HarryPotter
Honorary Moderator
Honorary Moderator
Posts: 19437
Joined: Mon Oct 23, 2006 12:48 pm
Location: Switzerland

Re: inofficial fw updates on cs 406

Unread post by HarryPotter » Tue Nov 26, 2013 7:55 pm

:?: The last FW Synology launched for CS406 was 2.0-0731.
*Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!*

DS718+ / DSM 6.2-23511 / ST4000VN000-2AH166 / SA400S37120G SSD cache /16 GB RAM
DS415+ / DSM 6.2-23511

LMS 7.9.1-166, 2 Squeezebox 3 + Boom

APC Smart UPS SUA750i

User avatar
Vaako
Versed
Versed
Posts: 229
Joined: Thu Jan 11, 2007 12:32 am

Re: inofficial fw updates on cs 406

Unread post by Vaako » Wed Jun 04, 2014 5:58 pm

Are the LED's working normal on the DSM 3.2 modded builds or does this issue stil exist?
Regards,
Vaako

USB Station 2 with DSM 3.2-1979 (altenative firmware) + (IPKG)
DS101g+ with DS107 DSM 3.1-1636 firmware
DC406e with DSM 3.1-1635 (thanks to Alfredo)
DS1511+ 2Gb RAM with DSM 6.1-15047 Update 2
DS1515+ 8Gb RAM with DSM 6.1-15047 Update 2 + 2x DX510

kbird
Student
Student
Posts: 75
Joined: Sun Jul 01, 2007 10:19 pm

Re: inofficial fw updates on cs 406

Unread post by kbird » Fri Jun 06, 2014 9:29 pm

you can control the LEDs with Linux commands in a script file if needed , I have done it with my 107e ( now a 109j) , think I posted in one of the 107e threads how to do it...

M.
DS_107e as a 109j
Using 4.2.3254
Esata not Working as 109j

User avatar
Vaako
Versed
Versed
Posts: 229
Joined: Thu Jan 11, 2007 12:32 am

Re: inofficial fw updates on cs 406

Unread post by Vaako » Sun Jun 08, 2014 7:11 pm

kbird wrote:you can control the LEDs with Linux commands in a script file if needed , I have done it with my 107e ( now a 109j) , think I posted in one of the 107e threads how to do it...

M.
Hi kbird,

I can not find the post you mention.
Wil you put the link here please of that post?

Thanks in advance!
Regards,
Vaako

USB Station 2 with DSM 3.2-1979 (altenative firmware) + (IPKG)
DS101g+ with DS107 DSM 3.1-1636 firmware
DC406e with DSM 3.1-1635 (thanks to Alfredo)
DS1511+ 2Gb RAM with DSM 6.1-15047 Update 2
DS1515+ 8Gb RAM with DSM 6.1-15047 Update 2 + 2x DX510

kbird
Student
Student
Posts: 75
Joined: Sun Jul 01, 2007 10:19 pm

Re: inofficial fw updates on cs 406

Unread post by kbird » Mon Jun 09, 2014 1:48 am

there are many posts regarding this but you are right I can't find my one
but searching script and led (1st link) gets me many.
http://forum.synology.com/enu/viewtopic ... script+led

seems there was an Android app
http://forum.synology.com/enu/viewtopic ... ed#p202498

and a 3rd Party App

http://forum.synology.com/enu/viewtopic ... ed#p116590


Good threads

http://forum.synology.com/enu/viewtopic ... ed#p203154

http://forum.synology.com/enu/viewtopic ... 19#p158835

http://forum.synology.com/enu/viewtopic ... 27&t=20485

http://forum.synology.com/enu/viewtopic ... ed#p115650.

I'll find the stuff I have if you needed it and post.
DS_107e as a 109j
Using 4.2.3254
Esata not Working as 109j

Alfredo
Versed
Versed
Posts: 276
Joined: Mon Jan 26, 2009 5:12 pm

Re: firmware 1636 on cs 406

Unread post by Alfredo » Mon Jun 09, 2014 2:26 pm

pjhwils wrote:Hi Alfredo, I had my CS406e on 3.1 1635, which worked fine, except for an rsync bug that made it impossible to backup from a DSM4.2 station to this 3.1. Synology delivered a fix for this, but only for version 1637: the last version for the x07 series, but not available for the x06 series.

I then decided to make a CS407e out of my CS406e by updating the synoinfo.conf, but installation with DS Assistant (with DSM 3.1 1637 for 407e) crashed and rendered my box empty with no fw, expecting a fw for CS406e. It is only accessible via telnet with a secret password, known by Synology only. DS Assistant expects at least a 1637 for the CS406e.

Do you happen to have a newer (1637 onwards) version for the CS406e? I'd be very thankful!
Very late reply...
My CS406 is currently gathering dust at home (while I am some place else). If enough people ask for it though, I'll create a new set of builds for v1637.
CS406 - DSM 2.2 0942 (modified from CS-407e)

edmond
Versed
Versed
Posts: 282
Joined: Sat Jan 06, 2007 10:10 am

Re: inofficial fw updates on cs 406

Unread post by edmond » Tue Jun 17, 2014 4:05 pm

Hi Alfredo

that would be great an update for the cs406

InKLy
I'm New!
I'm New!
Posts: 1
Joined: Tue Sep 09, 2014 6:31 am

Re: inofficial fw updates on cs 406

Unread post by InKLy » Tue Sep 09, 2014 6:34 am

Yes would be great!!

could you add openssl fix?

Post Reply

Return to “x01/x06/x07 Legacy Discussion”