NAS drives not "reconnecting" when I boot up

Questions about file sharing through NFS/CIFS/AFP? Post it here!
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:

https://account.synology.com/support/su ... p?lang=enu



2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
naga
Student
Student
Posts: 78
Joined: Thu Oct 20, 2011 11:30 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by naga » Sun Oct 14, 2012 9:36 pm

Update:

It worked then stopped, so it has not solved the problem.

keiron99
Experienced
Experienced
Posts: 147
Joined: Tue Dec 13, 2011 10:45 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by keiron99 » Fri Feb 22, 2013 1:47 pm

Revisiting this thread after a while. I have just reinstalled Windows 7 and hope that this problem would somehow have fixed itself. No such luck!

Has anyone found a solution?

Does the problem persist with Windows 8?

naga
Student
Student
Posts: 78
Joined: Thu Oct 20, 2011 11:30 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by naga » Thu May 23, 2013 1:37 am

As far as I can see, it is a matter of the disks hibernating. After several months of messing around, I have found that if the NAS is already awake, all mapped drives connect without problems. However, after the latest DSM 4.2 update, the NAS is taking even more time to wake up unfortunately. One of the many niggling frustrations with the Synology.

keiron99
Experienced
Experienced
Posts: 147
Joined: Tue Dec 13, 2011 10:45 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by keiron99 » Sun May 26, 2013 8:17 pm

My my drives don't hibernate, yet still they don't connect.


This is the single most frustrating thing about my NAS. I have found work arounds for every other little issue, but not this one.

naga
Student
Student
Posts: 78
Joined: Thu Oct 20, 2011 11:30 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by naga » Sun May 26, 2013 8:39 pm

keiron99 wrote:My my drives don't hibernate, yet still they don't connect.


This is the single most frustrating thing about my NAS. I have found work arounds for every other little issue, but not this one.
A good tip given previously: create a user on the NAS. Create a user with the same name and password on the Windows computer that you use when you log in. Any mapped drives SHOULD automatically connect if the NAS is not in hibernation, assuming you set them up to automatically reconnect on log in and set the user name and password to the user you set on the NAS.

I only have a problem if my NAS is hibernating. If I use my iPad to get the discs spinning before I boot my Windows PC, it connects all mapped drives no problem.

If you are still having problems having tried the above, then I suspect something else is going on.

It should be possible for Synology to fix this, but they don't seem interested in the little things that actually make the user experience so frustrating.

paul13
Beginner
Beginner
Posts: 26
Joined: Sun May 26, 2013 11:57 am

Re: NAS drives not "reconnecting" when I boot up

Unread post by paul13 » Mon May 27, 2013 8:54 am

I have spend a good day to better understand. Have been reading and trying many (read MANY!!) articles (regedits / credidentials etc etc). HOWEVER it is down to Windows-7, handling different than XP at start-up. In one of the articles on MSDN this is clearly described and acknowledged as a change request (that has been rejected) as there are workarounds.
As some created the same login credentials on Windows as NAS. I do not want to change the security structure to support the NAS.

The workaround for me is a batch file in startup that is using the NET USE command. I have created mine it works perfectly and can reproduce the issue or get it work without any problem time after time. I will document later today and submit how it works for me now in the coming day.

naga
Student
Student
Posts: 78
Joined: Thu Oct 20, 2011 11:30 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by naga » Mon May 27, 2013 11:51 am

paul13 wrote: As some created the same login credentials on Windows as NAS. I do not want to change the security structure to support the NAS.
That still does not solve the problem if the NAS is hibernating. I still have to wait for the disks to spin up before I can connect. So that is not really a solution.
The workaround for me is a batch file in startup that is using the NET USE command. I have created mine it works perfectly and can reproduce the issue or get it work without any problem time after time. I will document later today and submit how it works for me now in the coming day.
Look forward to seeing your workaround. The issue is driving me nuts!

Thanks Paul.

cfuttrup
Virtuoso
Virtuoso
Posts: 1339
Joined: Fri May 09, 2008 8:01 pm
Location: Denmark
Contact:

Re: NAS drives not "reconnecting" when I boot up

Unread post by cfuttrup » Mon May 27, 2013 1:48 pm

paul13 wrote:The workaround for me is a batch file in startup that is using the NET USE command. I have created mine it works perfectly and can reproduce the issue or get it work without any problem time after time. I will document later today and submit how it works for me now in the coming day.
Thanks. Please share ... I look forward to see your batch file.

Regards,
Claus

paul13
Beginner
Beginner
Posts: 26
Joined: Sun May 26, 2013 11:57 am

Re: NAS drives not "reconnecting" when I boot up

Unread post by paul13 » Mon May 27, 2013 2:42 pm

I created a batch file with the following content. copy /paste to a batch-file and follow the instructions described in it.


@echo off

REM *************************************************************************************************************************
REM * version 1.0 27 May 2013
REM * pvh : first version
REM *
REM * READ FIRST !!
REM * - Update the variables with your correct information
REM * - Save in the user home directory
REM * - Give this file a .bat extension : e.g. Mapds.bat
REN *
REM * - you COULD test in the command prompt:
REM * 1. Start - search - CMD <ENTER>
REM * 2. net use <ENTER> (will show active mapping, if Z: drive is mapped perform step 5)
REM * 3. Mapds <ENTER> (to run batch file)
REM * 4. net use <ENTER> (should show your drive mapped. if you start file explorer, you will see it as well)
REM * 5. net use Z: /DELETE <ENTER> ( OPTIONAL : will remove the Z: drive mapping and you can try again at step 2)
REM *
REM * - copy file (or make shortcut) to c:\Users\YYY\Appdata\Roaming\Microsoft\Windows\Start menu\Programs\Startup
REM * - Replace YYY in above line for the real username
REM * - P.s. it is are hidden directories so you may need to set show hidden files in the file-explorer
REM * - Make sure you don't have the directory mapping manual in de file explorer (disconnect/delete otherwise first)
REM * - Logoff/logon or restart system
REM *
REM * - During logon you will see a CMD screen quickly show and disappear.(that is this batch-file)
REM * - If the CMD stays, it can't logon to the NAS. <cntrl> + C to stop. You may want to use the described test procedure
REM *
REM * IF you remove all the REM lines is MIGHT executed a split-second faster, but you lose information for later
REM ***********************************************************************************************************************

REM ******************** VARIABLES ***************************************************
REM * update in "set" command below:
REM *
REM * Drive = is the PC driveletter to map the NAS (use a letter that is not used yet)
REM * Mappath = is the path on the NAS to connect to
REM * User = user name for NAS logon (set during create user on the NAS)
REM * Passwd = password for NAS logon (set during create user on the NAS)
REM *
REM * Put NO spaces after the equal sign !!!
REM **********************************************************************************

set Drive=Z:
set Mappath=\\DISKSTATION\paul
set User=paul
set Passwd=123456

REM **********************************************************************************
REM The command below is for test only (remove REM remark and test in CMD if needed)
REM **********************************************************************************

REM echo %Drive% %Mappath% /USER:%User% %Passwd% /PERSISTENT:NO


REM **********************************************************************************
REM * The REAL action, make no changes here!
REM **********************************************************************************

net use %Drive% %Mappath% /USER:%User% %Passwd% /PERSISTENT:NO

dmgtree
I'm New!
I'm New!
Posts: 1
Joined: Tue Nov 04, 2014 11:00 am

Re: NAS drives not "reconnecting" when I boot up

Unread post by dmgtree » Tue Nov 04, 2014 11:06 am

Thanks Claus and Naga

That solution worked beautifully once I had matched the DS password with my laptop password.

Thanks again, that was getting really annoying but now is sorted.

Cheers
Dave :D

Watchmaker
I'm New!
I'm New!
Posts: 1
Joined: Wed Aug 28, 2013 6:25 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by Watchmaker » Tue Mar 03, 2015 2:14 pm

THANK YOU!!! The bat file worked perfectly. Now I can automatic :D incremental backups with Paragon.

BlackMilk
I'm New!
I'm New!
Posts: 4
Joined: Tue Dec 23, 2014 6:29 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by BlackMilk » Sun Nov 01, 2015 3:39 pm

naga wrote: Start > Run > type "gpedit.msc" (without quotes) click ok. Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon > Always wait for the network at computer startup and logon set this to Enable then reboot.
Thank you this is working for me at the minute. I've had this problem with Windows 7, 8 and 10.

geoffp
I'm New!
I'm New!
Posts: 3
Joined: Mon Dec 08, 2014 11:20 pm

Re: NAS drives not "reconnecting" when I boot up

Unread post by geoffp » Fri Aug 10, 2018 10:24 am

I think this is a Synology NAS problem.

I fixed it with my Synology DS211 running DSM 6.2 by selecting SMB3 in File Services->SMB->Advanced Settings->Maximum SMB Protocol. It was set to SMB1 for some reason. I also changed Minimum SMB Protocol to SMB2 (the highest option) and enabled SMB2 Lease.

Enabling SMB3 on the NAS seems better than making Windows use SMB1 or start slowly.

Post Reply

Return to “File Sharing: Windows, Mac OS X, Linux”