Download Station does not work after changing the router

Post your questions about using our Download Station here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form: ... p?lang=enu

2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.
I'm New!
I'm New!
Posts: 2
Joined: Fri Nov 18, 2011 11:00 am

Download Station does not work after changing the router

Unread post by allp84 » Thu Feb 23, 2012 9:26 pm


I recently changed from ISP and got a new router (a better one). The change was pretty easy and everything was up and running in no time, except the download station.
When I search for a file, all i get is a message "bezig met zoeken..." (dutch for "searching"), It will never find anything. However, it is possible to search for files from the Synodroid android app. Adding a torrent is possible, however it is just being added in the download list (under the name that I searched for). The downloaddoes not start, eventually geting into a connection time-out.

I tried resetting the DSM without any success. I also tried to disable the download station from the configuration panel, and after that resetting.
I opened all ports on the router for the download station, and eventually put the entire NAS in the DMZ. But this didnt work either. To be honest, I dont think the problem is in the port forwarding.
It might be the DHCP, the new router starts each ip with, my synology is set to (which was the old ip address from my previous router). However, all other functions work perfectly, including photo station and remote web-access.

I've searched around this forum for a solution but I could not find anyone with this problem. The only solution I can think of is by upgrading to the new DSM 4.0, but that is a beta and I havent found anything that this might solve my problem.

I have a DS212j with DSM 3.2-1955.

Post Reply

Return to “Download Station”