Couldn't connect to database / DBI connection failed

Discussion room for the Media Server package by Logitech
Forum rules
Please note the Disclaimer before modifying your Synology Product.

Couldn't connect to database / DBI connection failed

Postby texmex » Fri Jul 17, 2009 12:05 pm

Hi,

after searching many threads, I still did not find a solution to my problem. When starting my Synology DS-107+ (DSM 2.1-0832) and the Squeezecenter 7.3.2 package, SC usually won't start running. I tried un-installing and re-installing the SC many times. Result: it will always run the first time after the installation, but not thereafter. Or only accidentally: after stopping / running the package in the package manager, it would sometimes really start after several tries... I also tried with SSODS in different versions (3.16, 3.17, 3.18) and SC (7.2.1, 7.3.2, 7.3.3), but wouldn't help either, I always get the same error. Currently I have SSODS removed and have installed the SC package that I downloaded from the Synology website. btw: enabling or disabling "MySQL" under Web Services did not help.

Any help would be greatly appreciated! :)

My log looks like this:
[09-07-17 12:24:37.0513] Slim::Schema::Storage::throw_exception (70) Error: DBI Connection failed: DBI connect('hostname=127.0.0.1;port=9092;database=slimserver:mysql_socket=/volume1/@appstore/SqueezeCenter/Cache/squeezecenter-mysql.sock','slimserver',...) failed: Can't connect to MySQL server on '127.0.0.1' (111) at /volume1/@appstore/SqueezeCenter/CPAN/DBIx/Class/Storage/DBI.pm line 652
[09-07-17 12:24:37.0748] Slim::Schema::Storage::throw_exception (70) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/volume1/@appstore/SqueezeCenter/Slim/Schema/Storage.pm line 70)
frame 1: Slim::Schema::Storage::throw_exception (/volume1/@appstore/SqueezeCenter/CPAN/DBIx/Class/Storage/DBI.pm line 658)
frame 2: DBIx::Class::Storage::DBI::_connect (/volume1/@appstore/SqueezeCenter/CPAN/DBIx/Class/Storage/DBI.pm line 616)
frame 3: DBIx::Class::Storage::DBI::_populate_dbh (/volume1/@appstore/SqueezeCenter/CPAN/DBIx/Class/Storage/DBI.pm line 543)
frame 4: DBIx::Class::Storage::DBI::ensure_connected (/volume1/@appstore/SqueezeCenter/Slim/Schema/Storage.pm line 29)
frame 5: (eval) (/volume1/@appstore/SqueezeCenter/Slim/Schema/Storage.pm line 29)
frame 6: Slim::Schema::Storage::dbh (/volume1/@appstore/SqueezeCenter/Slim/Schema.pm line 132)
frame 7: Slim::Schema::init (/volume1/@appstore/SqueezeCenter/Slim/Music/Info.pm line 77)
frame 8: Slim::Music::Info::init (/volume1/@appstore/SqueezeCenter/slimserver.pl line 369)
frame 9: main::init (/volume1/@appstore/SqueezeCenter/slimserver.pl line 486)
frame 10: main::main (/volume1/@appstore/SqueezeCenter/slimserver.pl line 1050)

[09-07-17 12:24:37.0977] Slim::Schema::init (135) Error: Couldn't connect to database! Fatal error: [Inappropriate ioctl for device] Exiting!
[09-07-17 12:24:37.1035] Slim::Schema::init (135) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/volume1/@appstore/SqueezeCenter/Slim/Schema.pm line 135)
frame 1: Slim::Schema::init (/volume1/@appstore/SqueezeCenter/Slim/Music/Info.pm line 77)
frame 2: Slim::Music::Info::init (/volume1/@appstore/SqueezeCenter/slimserver.pl line 369)
frame 3: main::init (/volume1/@appstore/SqueezeCenter/slimserver.pl line 486)
frame 4: main::main (/volume1/@appstore/SqueezeCenter/slimserver.pl line 1050)
texmex
I'm New!
I'm New!
 
Posts: 2
Joined: Mon Jul 06, 2009 7:03 pm

Re: Couldn't connect to database / DBI connection failed

Postby texmex » Sun Aug 02, 2009 11:02 am

it seems that this error is corrected with the new Disk Station Manager --> I installed the the beta of DSM 2.2 along with the Squeezecenter 7.3.3 package and everything runs smoothly now.

Maybe you also want to install the beta, if you experience the same problems as I've had
texmex
I'm New!
I'm New!
 
Posts: 2
Joined: Mon Jul 06, 2009 7:03 pm

Re: Couldn't connect to database / DBI connection failed

Postby EowynCarter » Sat Sep 05, 2009 2:22 pm

Hang on. 7.3.3 ?

Do'h !
Running 2.2 with SquezzeCenter 7.3.2 don't goes well.
EowynCarter
Apprentice
Apprentice
 
Posts: 97
Joined: Tue Feb 24, 2009 10:24 pm


Return to Logitech Media Server

Who is online

Users browsing this forum: No registered users and 0 guests