Error: Authorization failed

Questions regarding Subversion Server may go here
Forum rules
Please note the disclaimer before modifying your Synology Product.

Re: Error: Authorization failed

Postby mero909 » Thu Feb 12, 2009 6:23 pm

The solution I found is that I was using "svn" protocol instead of "http".

Ex. svn://myrepositoryurl.com/trunk/ = WRONG
Ex. http://myrepositoryurl.com/trunk/ = CORRECT

The svn protocol allowed me to do a checkout, but disallowed a commit as this was "read only".

Hope this helped.
mero909
I'm New!
I'm New!
 
Posts: 1
Joined: Thu Feb 12, 2009 6:19 pm

Re: Error: Authorization failed

Postby Risto » Thu Feb 12, 2009 6:39 pm

Hi mero909,
you must have something wrong in your configuration, as it should work with svn Protocol (default port 3690) and not over HTTP (default port 80) if you followed the instructions in Synology Wiki for Subversion installation.

Cheers,
Risto
Risto
Student
Student
 
Posts: 62
Joined: Wed Oct 25, 2006 7:03 pm

Re: Error: Authorization failed

Postby dathui » Thu Apr 16, 2009 2:35 pm

I've finally managed to get the svn server running but I'm having the same trouble as the other posters(tortoise svn doesn't ask for a psw and seem to allow anon checkouts), should the lines in the passwd file be
Code: Select all
[users]
#user = psw

or
Code: Select all
[users]
user = psw

same goes for the svnserve.conf, my current lines are
Code: Select all
[general]
# anon-access = none
# auth-access = write
# password-db = passwd
### Uncomment the line below to use the default authorization file.
# authz-db = authz
# realm = my repo name


should i remove the #'s at the beginning of the lines?
dathui
I'm New!
I'm New!
 
Posts: 3
Joined: Thu Apr 16, 2009 2:29 pm

Re: Error: Authorization failed

Postby Risto » Thu Apr 16, 2009 8:01 pm

> should i remove the #'s at the beginning of the lines?
YES!
# means everything to the right of it is just a comment.

Cheers,
Risto
Risto
Student
Student
 
Posts: 62
Joined: Wed Oct 25, 2006 7:03 pm

Re: Error: Authorization failed

Postby magicmoux » Tue Sep 28, 2010 1:11 pm

Hi,

one year and a half later... Time again to awaken this post ;)

We have just setup the svn package on our RS409 NAS, following the synology wiki documentation for installing and configuring the subversion server and test repository.
During first configuration and checkout, we encountered no problem and were correctly asked user authentication.
However, whenever we try to commit a file we get the post-submit error message: Can't remove file \.svn\prop-base\testlocal.txt.svn-revert, Access denied
It seems the file was never created at all during the svn add phase.
Windows user and svn user seems to be configured correctly (the windows useraccount has full access to the share).
Some posts on the Internet advised to modify the samba conf to add the option "delete readonly = yes", we tried that to no avail...

Could Tortoise use another windows account (like system account) to manage the working-copy .svn folder ?

The system configuration is as follow:
RS409 hosting a working copy on a share (Samba 3.2.8 )

svnserve.conf:
anon-access = none
auth-access = write
password-db = passwd

SVN Client : TortoiseSVN 1.6.10, Build 19898 - 64 Bit running on windows 7 64bits

If anybody encountered this and has some light to share about how to get this working, please feel free ?

Thanks,
Max.
magicmoux
I'm New!
I'm New!
 
Posts: 2
Joined: Tue Sep 28, 2010 12:44 pm

Re: Error: Authorization failed

Postby kopa » Wed Aug 08, 2012 8:47 am

I have same problem. I've used http://forum.synology.com/wiki/index.php/Step-by-step_guide_to_installing_Subversion and do every step except SSH and HTTP sections. Then I've tried to checkout. I was asked username and password by tortoise, but when I entered data, that I've stored in passwd file - tortoise said Authorization failed. I can't find some log or smth to determine if I just made a mistake, while typing password or svn user wasn't created at all. Is there any avialable log of svn server process? or maybe anyone can help with my problem?
kopa
I'm New!
I'm New!
 
Posts: 1
Joined: Wed Aug 08, 2012 8:36 am

Re: Error: Authorization failed

Postby panel » Mon Nov 12, 2012 12:03 am

I got same problem, but adding

realm = I am your test repository

to svnserver.conf helped
panel
I'm New!
I'm New!
 
Posts: 9
Joined: Mon Aug 08, 2011 11:39 am

Re: Error: Authorization failed

Postby droschmisch » Tue Jul 30, 2013 4:36 pm

Hi people, I had the same problem.

Solved it like this:

in the file svnserve.conf I wrote this (directly under [general]):

[general]
anon-access = none
auth-access = write
password-db = passwd
realm = /volume1/svn/%myfirstrepos%

%myfirstrepos% is your repository

and watch out for the missing # at the beginning of each line!

Greetings!
droschmisch
I'm New!
I'm New!
 
Posts: 4
Joined: Wed Oct 10, 2012 11:29 am

Previous

Return to Subversion Server

Who is online

Users browsing this forum: No registered users and 1 guest