Can't connect from our Domaincontroller(unexpected error 59)

All questions pertaining to Windows Active Directory Service can go here
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.

Can't connect from our Domaincontroller(unexpected error 59)

Postby Bridge » Tue Jun 17, 2008 9:35 am

Hi

We have a problem connecting to our Synology Server via a Domaincontroller.

We have serveral Servers (all Win2003 R2) and Workstations (WindXP / Vista) connecting to our Synology server with ADS integration.
All the clients can access our Synology server perfectly with ADS given permissions.
Servers in our domain can connect to the Synology server as well.
only our two Domaincontrollers can't connect to our Synology server and we dont know why.
When we try to map a drive we get the error 59, unexpectet error occurred...

We couldn't find any difference between our usual servers and those beeing a domain controller.

Is there any solution to our problem?
Playing with the lmcompatibilitylevel didn't help either.

Best Regards

Philippe
Bridge
I'm New!
I'm New!
 
Posts: 9
Joined: Fri Jun 06, 2008 2:05 pm

Re: Can't connect from our Domaincontroller(unexpected error 59)

Postby Franklin » Tue Jun 17, 2008 10:21 pm

Greetings Bridge

Please try following suggestions

1. Map the drive using the IP address of the Synology Box
1a. It may be necessary to map the drive using the net use commands.
2. Make sure that the local device is free, or use a different device name
3. Though unlikely, (but worth a shot) the guest account can be causing interference. Try disabling the guest account on the Synology system, and then remap the drive.

Hope this helps
**Franklin is not available**
**Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!**
Library ~ SynologyWiki ~ Synology FAQ ~ Compatibility Lists
Forum Links ~ Forum Policy ~ 3rd-party forums ~ Help us help you ~ Posting Images
Demo Links ~ DSM GUI ~ Photo Station
Downloads ~ Firmware Downloads ~ Beta Program
Support ~ Support Form ~ Submit Kernel ~ Synology eNews
User avatar
Franklin
Synology Inc
Synology Inc
 
Posts: 6664
Joined: Sat Oct 14, 2006 11:33 pm
Location: Washington, USA

Re: Can't connect from our Domaincontroller(unexpected error 59)

Postby Bridge » Wed Jun 18, 2008 4:11 pm

Thank you for your reply.

1. Tried to map via IP address, no luck.
1a. Already tried with net use, that's why I got the errorcode 59
2.checked that, seems to be ok.
3.the first thing I did was to disable the guest account.

I even tried the newest Firmware with no luck at all.
Bridge
I'm New!
I'm New!
 
Posts: 9
Joined: Fri Jun 06, 2008 2:05 pm

Re: Can't connect from our Domaincontroller(unexpected error 59)

Postby Franklin » Wed Jun 18, 2008 10:18 pm

Greetings Bridge

Some further suggestions from one of our ADS engineers

1. Sync Synology Server time with domain controller and retry to map drive.
2. If map drive in domain controller is used with domain user name, please add domain name prefix, ex: DOMAIN_NAME\domain_user_name.
3. Try to map drive with another (domain) account.
4. Checking Network issue, including firewall , anti-virus, DS's NetBIOS name can be used in domain controller.
5. Checking the domain security policy and domain controller security policy.
6. Reboot DS and retry.


If none of the above solutions work, please contact online support, the link is in my signature.

Hope this helps
**Franklin is not available**
**Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!**
Library ~ SynologyWiki ~ Synology FAQ ~ Compatibility Lists
Forum Links ~ Forum Policy ~ 3rd-party forums ~ Help us help you ~ Posting Images
Demo Links ~ DSM GUI ~ Photo Station
Downloads ~ Firmware Downloads ~ Beta Program
Support ~ Support Form ~ Submit Kernel ~ Synology eNews
User avatar
Franklin
Synology Inc
Synology Inc
 
Posts: 6664
Joined: Sat Oct 14, 2006 11:33 pm
Location: Washington, USA

Re: Can't connect from our Domaincontroller(unexpected error 59)

Postby Bridge » Fri Jun 20, 2008 2:05 pm

I tried what you suggested..

1.Same timezone, same time (same minutes)
2.I tried that with the domain names.. tried domain\user or user@domain with no luck.
3.tried net use with /user:domain\user pass with no luck. Same problem.
4.There is no Firewall running on the ADS, tried to deactivate the enhanced IE security that comes with R2, also no luck. Even added the name manually to the DNS, but can't connect to be box via IP either.
5.The Domain ecurity and also the domain controller security is set to "not defined"
6.By rebooting the DS you mean rebooting the machine I guess. No luck so far. Try to restart it some times this weekend when nobody else needs it.

"7"I tried to explain my problem to you support team with no luck...saying that the R2 versions aren't tested yet and I should download the new firmware, which I did.

I'm getting a little desperate..have no idea what to do...Listening with wireshark the TCP/IP protocol the handshake happens and the windows server suddenly sends an "end".
It must be some kind of security or and negotiation between those two. I can ping it, can access the web interface, can connect with telnet but just can't connect to the shared drives...
Bridge
I'm New!
I'm New!
 
Posts: 9
Joined: Fri Jun 06, 2008 2:05 pm

Re: Can't connect from our Domaincontroller(unexpected error 59)

Postby Franklin » Fri Jun 20, 2008 8:02 pm

Greetings Bridge

Unfortunately, I have no further suggestions for you, please continue your conversation with our online support team. Please note that Error59 is an ambiguous Windows Network Error message, and the suggestions listed are the most common causes of this error.

If you cannot access the data using the samba or net use, there is another configuration error within the client access the Synology system which is causing the error. You may elect to use Windows GUI to attempt to map the drive, or use windows explorer and set it to use the FTP protocol as a temporary basis to access the data.

Hope this helps
**Franklin is not available**
**Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!**
Library ~ SynologyWiki ~ Synology FAQ ~ Compatibility Lists
Forum Links ~ Forum Policy ~ 3rd-party forums ~ Help us help you ~ Posting Images
Demo Links ~ DSM GUI ~ Photo Station
Downloads ~ Firmware Downloads ~ Beta Program
Support ~ Support Form ~ Submit Kernel ~ Synology eNews
User avatar
Franklin
Synology Inc
Synology Inc
 
Posts: 6664
Joined: Sat Oct 14, 2006 11:33 pm
Location: Washington, USA

Re: Can't connect from our Domaincontroller(unexpected error 59)

Postby Bridge » Thu Jul 24, 2008 1:57 pm

After some weeks ago, I rebooted our server and we could finally access our Rackstation.
We have no idea why it was working since then.
Unfortunately we had to restart our server recently and like we feared, we can't connect to our rackstation anymore.
We haven't changed anything on the server/registry/programs/network.

I have absolutely no clue what could be the problem for our phenomenon...
Bridge
I'm New!
I'm New!
 
Posts: 9
Joined: Fri Jun 06, 2008 2:05 pm

Re: Can't connect from our Domaincontroller(unexpected error 59)

Postby Franklin » Thu Jul 24, 2008 10:54 pm

Greetings Bridge-

I am out of suggestions with the cause of your network error.
I would suggest that you contact online support for further assistant, or consult with a network consultant who is at your network who can see what settings you are using.

Last thought: After closing hours, or on the weekend, shut down the entire network
Power up Broadband connection
==Wait two minutes==
Power up Router or DHCP Server, and all switches/hubs
==Wait two minutes, or until device is finished booting==
Power up all servers, and Synology Systems
==Wait for all servers to be boot
Login to the Router's DHCP settings
Purge any old DHCP settings
Assigned all fixed IPs to all servers, domain controllers, Synology systems, etc.

Make sure that the connection between each server, domain controller, Synology system is stable

Power up random client computers to make sure that the network connection is stable.

Hope this helps
**Franklin is not available**
**Please do not Private Message me for support questions; leave it on the forum so all members can learn. Thanks!**
Library ~ SynologyWiki ~ Synology FAQ ~ Compatibility Lists
Forum Links ~ Forum Policy ~ 3rd-party forums ~ Help us help you ~ Posting Images
Demo Links ~ DSM GUI ~ Photo Station
Downloads ~ Firmware Downloads ~ Beta Program
Support ~ Support Form ~ Submit Kernel ~ Synology eNews
User avatar
Franklin
Synology Inc
Synology Inc
 
Posts: 6664
Joined: Sat Oct 14, 2006 11:33 pm
Location: Washington, USA

Re: Can't connect from our Domaincontroller(unexpected error 59)

Postby pdeleeuw » Tue Jul 29, 2008 11:00 pm

I found this can happen on almost any type of NAS drive, this applies mainly to 2003R2, Vista and longhorn...
This is because of a sequencing issue regarding IPV6 and IPV4.
If you set up on the R2 to allow LDap and change the GP to look at IPV4 first ... you will have no problems working with attached storages.
Change the GP to reflect the same in vista for IPV4 first ..
All will be fine.

Thx
Paul.
pdeleeuw
I'm New!
I'm New!
 
Posts: 2
Joined: Tue Jul 29, 2008 10:01 pm


Return to Windows AD Domain

Who is online

Users browsing this forum: No registered users and 2 guests