DS413 and DSM 4.2: loosing printer connection

Got questions on using your printer with our server? Post it here.
Forum rules
This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu

DS413 and DSM 4.2: loosing printer connection

Postby browetd » Fri Mar 08, 2013 6:38 pm

Hello,
I have just upgraded my DS413 to the new DSM version (4.2). I never had a problem of loosing printer connection. Since the upgrade, I am loosing regularly the printer (USB connected). The printer is not detected by the Synology Assistant... and sometimes when I try to attach the printer for scanning for instance, I got an "unknown error message, restart synology assistant". The only way to reconnect the printer is to restart the NAS (not very convenient). When the NAS is up, the printer is working again without additional actions. Anyone has an idea what I can do ? Bug in DSM 4.2 ? Thanks, Didier

Printer: Canon MP610
browetd
I'm New!
I'm New!
 
Posts: 2
Joined: Fri Mar 08, 2013 6:30 pm

Re: DS413 and DSM 4.2: loosing printer connection

Postby browetd » Fri Mar 15, 2013 2:56 pm

I made additional checks and tests... the printer is not seen after I switched it off for some time... Is USB port disconnected ? Any command/way available to stop/start the USB port to see if this is fixing the issue (easier than restart the NAS).

Thanks, Didier
browetd
I'm New!
I'm New!
 
Posts: 2
Joined: Fri Mar 08, 2013 6:30 pm

Re: DS413 and DSM 4.2: loosing printer connection

Postby dmartin » Sat Jun 22, 2013 2:52 pm

With New DS713 and DSM 4.2 I'm seeing the same problem. The USB printer (which worked with no problem on an older DS209) now disappears for some reason. I am suspicious that it might be connected with the disks spinning down after delay and am now trying without spin-down. Will report.
dmartin
I'm New!
I'm New!
 
Posts: 3
Joined: Sat Jun 22, 2013 2:49 pm

Re: DS413 and DSM 4.2: loosing printer connection

Postby dmartin » Sun Jun 23, 2013 10:11 am

I need to spend more time testing but ... it does look as if enabling "advanced hibernation" is what broke my USB printer connection. I unticked "advanced hibernation" and have not had the problem since. Will report back if the problem recurs.

Can anyone confirm this ?

The help information implies that some attached USB devices will have trouble with advanced hibernation, so I guess this is related.
dmartin
I'm New!
I'm New!
 
Posts: 3
Joined: Sat Jun 22, 2013 2:49 pm

Re: DS413 and DSM 4.2: loosing printer connection

Postby dmartin » Mon Aug 19, 2013 2:37 pm

The 'fix' that I described above works - most of the time. However my Win7 PC still occasionally looses contact with the printer (Samsung 4520 print/copy/scan) and the easiest (but tiresome) fix is to power cycle the DS713. Anyone else seeing this ?
dmartin
I'm New!
I'm New!
 
Posts: 3
Joined: Sat Jun 22, 2013 2:49 pm

Re: DS413 and DSM 4.2: loosing printer connection

Postby zeeforel » Sun Sep 08, 2013 5:56 pm

Having similar problems over here with 210j and my Canon Pixma 4200. Had issues in the past (2 years ago) but it was very stable since (even bi-directional info on inkt levels!!) until I upgraded to the latest DSM 4.3 one week ago.

Can not check about the hibernation because I do not know how, but I did a complete reinstall of the USB printer but cannot seem to get it working from the pc's in the house. Strange thing though is that the Airprint function seems to be working from my iPad...

Think Synology should pay a bit more attention to the printer server functionality!!

Solutions welcome. Thanks.
zeeforel
Trainee
Trainee
 
Posts: 16
Joined: Mon Aug 02, 2010 9:14 pm

Re: DS413 and DSM 4.2: loosing printer connection

Postby sav » Thu Sep 19, 2013 3:52 am

I have the same issue with a DS1513+ running DSM 4.3.
The USB printer works for a short while after a restart of the NAS - but then stops working.

Dave.
sav
I'm New!
I'm New!
 
Posts: 1
Joined: Thu Sep 19, 2013 3:49 am

Re: DS413 and DSM 4.2: loosing printer connection

Postby jtn6ln » Sat Nov 02, 2013 11:12 pm

I have the same problem. Had stable network printing to the Brother MFJ 7340 -- connected via usb to DS211j. Worked for years until upgrade to DSM4.3-3776. I read another post from October that Synology would have an upgrade addressing this in "2-3 weeks" and just upgraded again to 4.3-3776-3.
Still can't print to the Brother over the network.

Has anyone discovered a workaround, a solution?
jtn6ln
I'm New!
I'm New!
 
Posts: 1
Joined: Sat Nov 02, 2013 11:02 pm

Re: DS413 and DSM 4.2: loosing printer connection

Postby tsmccull » Sun Nov 03, 2013 4:42 pm

I attached an old Brother HL-2040 printer to my DS213j and the Synology finds it, but when I go to print to usbprinter it sometimes works, but more often just sits there with no error msg or results. However, in those cases, if I print to the HL-2040 printer that also appears in my list of available printers, it does print. Sometimes I even get a double copy of the printout, as though the usbprinter had spooled the file, but didn't want to start until a print to the HL-2040 printer selection triggered it.

Any ideas what I should check? Thanks.
tsmccull
I'm New!
I'm New!
 
Posts: 2
Joined: Sat Oct 19, 2013 7:05 pm


Return to Printer Server

Who is online

Users browsing this forum: No registered users and 2 guests