Indexing takes a long time..?

Questions about the Synology Photo Station can be placed here.
Forum rules
1) This is a user forum for Synology users to share experience/help out each other: if you need direct assistance from the Synology technical support team, please use the following form:
https://myds.synology.com/support/suppo ... p?lang=enu
2) To avoid putting users' DiskStation at risk, please don't paste links to any patches provided by our Support team as we will systematically remove them. Our Support team will provide the correct patch for your DiskStation model.

Indexing takes a long time..?

Postby apeka » Sun May 09, 2010 1:37 pm

For the first time I enabled the DNLA/mediastation in my DS107+ and connected my Sony Bravia tv to the network. The connection is ok and the nas is now visible in my tv's menu..
After that I copied 100 GB of photo files of my photo files to the "photo" folder on the NAS, mostly containing JPG's and some TIFF's..
Checking the photos shortly after on my tv I noticed that not all the pictures were visible yet: ("file not found"). I assume this has to do with the indexing still running?
The next morning I noticed my NAS is still constantly active with indexing and this is going on for almost a whole day now...Is this normal? How long does it usually take for approx. 100GB files to be indexed completely?
Also, will this indexing process start all over again when I add a new photo map with new photos to the ones already present, or will the indexing be limited to the new added and go faster then?
I also wonder if my harddisk, a 1 TB WD Green Power 24/7, will be overstressed when constantly being active for so long...Right now the hd temperature is 36 degrees C.
Can anybody explain what this index process means and if my DS107+ behaviour is normal..?
Thanks a lot!
apeka
Novice
Novice
 
Posts: 41
Joined: Sun Sep 28, 2008 1:30 pm

Re: Indexing takes a long time..?

Postby jekyll » Sun May 09, 2010 8:15 pm

apeka wrote:I noticed my NAS is still constantly active with indexing and this is going on for almost a whole day now...Is this normal? How long does it usually take for approx. 100GB files to be indexed completely?

Nobody can answer this as you have to take into consideration what other serbvices are in use for the ram & cpu, the encoding of the files etc... i would say a long time.. 50GB of photo's on a DS101G+ took 8days where as the DS410 would do it in a few hours.
apeka wrote:Also, will this indexing process start all over again when I add a new photo map with new photos to the ones already present, or will the indexing be limited to the new added and go faster then?

It will just index the new content ;)
apeka wrote:I also wonder if my harddisk, a 1 TB WD Green Power 24/7, will be overstressed when constantly being active for so long...Right now the hd temperature is 36 degrees C.

No! disks are hardcore! so an index isnt too bad, 36c is optimum drive temprature for a working drive!
apeka wrote:Can anybody explain what this index process means and if my DS107+ behaviour is normal..?

You'll find synoindexd is the index deamon, and ffmpeg is the photo indexing process.
Both processes are active when any media services are newly enabled or new content added.

Regards
www.jekyll.info

APC UPS1500RM2U
APC AP7920
Syno DS410
Syno DS509
Syno VS80
User avatar
jekyll
Wizard
Wizard
 
Posts: 1831
Joined: Thu Feb 28, 2008 7:55 pm
Location: Low Burnham, Epworth - UK

Re: Indexing takes a long time..?

Postby imcon » Mon May 10, 2010 3:59 pm

You have to consider that not only indexing of the media takes some time but also to create thumbnails take time - much more then indexing. You can see it as process Convert.
To understand the reason why it take so long it is good to know that for each uploaded photo/picture Synology DS station will create a new directory and 5 thumbnails each with with the different resolutions. Therefore in case that you upload 10 000 photos, DS station will create 50 000 additional JPGs (thumbnails). The additional directories and thumbnails can be seen only by the system, you will not see them.
Example: uploading of 100 000 photos mean that at the DS station will be stored additional 100 000 directories and together 600 000 photos.
Last edited by imcon on Mon May 10, 2010 8:37 pm, edited 1 time in total.
DS210+ / DSM 4.3 / 2xWD1002FBYS / running: Backups, FTP, Surveillance Station, VPN, Cloud Station, Syslog server
DS209+II / DSM 4.2 / 2xSAMSUNG HD753LJ 698.64 GB / running: Backups, FTP, WEB, Photo station, Squeezebox Server, Webalizer, Surveillance Station, VPN, Syslog server
DS107 / DSM 3.1 / 1xSAMSUNG HD321KJ 298.09 GB / running: Surveillance Station, Backups
User avatar
imcon
Apprentice
Apprentice
 
Posts: 87
Joined: Fri Jan 30, 2009 12:10 pm
Location: Czech Republic

Re: Indexing takes a long time..?

Postby apeka » Mon May 10, 2010 6:27 pm

@Jekyll and imcon:
Thanks for taking time to answer my questions...
Though I own the DS107+ for several years now, it's been the first time that I activated the mediaserver and added photos. BTW: I checked all options in the DSM -> Applications -> Media Server: media server, browsing settings and all the checkboxes in dma compatability. I suppose that's right?
I only added photos to the photo map yet and don't even dare to add music and video files now, but maybe that doesn't take so much indexing as it does with photos..?
Anyway, from your answers I can now understand that the DS had a lot of work to do with creating the thumnails and needed a lot of time..Still I don't understand the creating of five different thumbnails, but I don't know too much about the way it works of course..After taking almost two days the DS has finished the indexing job now...Actually not too bad for working 100GB of files...
apeka
Novice
Novice
 
Posts: 41
Joined: Sun Sep 28, 2008 1:30 pm


Return to Photo Station

Who is online

Users browsing this forum: No registered users and 5 guests